 API browser of acfValidator100 COM module
Interface version: | 1.00
Interface date: | 3 Aug 2025

The acfValidator100 is an ATL COM module which provides methods to browse, search, and validate services from the tariffs "005::Fallpauschalen" and "TMA::LKAAT", respecively. Furthermore, the acfValidator100 can group a set of TMA services to achieve the correct Ambulatory Case Flaterate (ACF) service. |  | space
Interfaces |  | 5 interface
IAcfValidator | Main interface for the database handling and global parameter settings |
ISearch005 | Search and browse functionality of services over tariff catalog "005::Fallpauschalen" |
ISearchTMA | Search and browse functionality of services over tariff catalog "TMA::LKAAT" |
IValidate005 | Validation of "005::Fallpauschalen" services according to the rules |
IValidateTMA | Validation of "TMA::LKAAT" services according to the rules |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important documents about the usage and handling |  |
Document | What to do in a 64bit environment - is there a 64bit Sumex1 COM dll? |
Document | General usage of the migelValidator100 COM module - an overview |
Document | Important Features of the acfValidator100 COM module |
Document | acfValidatorServer100: Introduction, overview and usage of the Restful Webservice Server |

© by sumex1.net - all rights reserved


  • acfValidator100
  • IAcfValidator

IAcfValidator interface |  | V1.00/ 3 Aug 2025
The IAcfValidator interface handles connections to the database holding two tariff catalogs, namely "005::Fallpauschalen" and "TMA::LKAAT". It provides methods to handle the database connection, to set and retrieve general database parameters, and retrieve information about the covered tariff catalogs. A connection to the database must be opened via IAcfValidator::Open method before any methods dealing with tariff catalogs can be used. Furthermore to do any work you get an instance of all dependent interfaces with the appropriate get function e.g. IValidateTMA, ISearchTMA, IValidate005, and ISearch005. |  | space
space
Methods |  | 5 methods
Close | Closes the tariff catalog database. |
GetAbortInfo | Fetches the abort/error information if there is any stored |
GetTariff005 | Retrieves the information for the "005::Fallpauschalen" tariff catalog |
GetTariffTMA | Retrieves the information for the "TMA::LKAAT" tariff catalog |
Open | Opens the tariff catalog database |
space
Properties |  | 16 properties
[get] CreateAcfValidator | Creates an instance of the main IAcfValidator interface |
[get] CreateSearch005 | Create an instance of the ISearch005 interface |
[get] CreateSearchTMA | Create an instance of the ISearchTMA interface |
[get] CreateValidate005 | Create an instance of the IValidate005 interface |
[get] CreateValidateTMA | Create an instance of the IValidateTMA interface |
[put] DestructAcfValidator | Destructs/invalidates a main instance of the IAcfValidator interface |
[put] DestructSearch005 | Destructs/invalidates this ISearch005 interface instance |
[put] DestructSearchTMA | Destructs/invalidates this ISearchTMA interface instance |
[put] DestructValidate005 | Destructs/invalidates this IValidate005 interface instance |
[put] DestructValidateTMA | Destructs/invalidates this IValidateTMA interface instance |
[get/put] EnableLog | Get and Set the log activity for the module |
[get/put] Language | Get and Set the language for the miscValidator module |
[get] ModuleVersion | Get the version of the acfValidator module |
[get] ModuleVersionText | Get the textual version of the miscValidator module |
[get] WildCard | Get and Set the match-all wildcard character for SQL queries. |
[get] WildCharacter | Get and Set the "match any single character" wildcard character for SQL queries. |
space |


  • IAcfValidator
  • Close

IAcfValidator::Close method |  |  | space
Closes the tariff catalog database. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAcfValidator/Close
[JSON input data] | pIAcfValidator: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Close( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IAcfValidator
  • GetAbortInfo

IAcfValidator::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAcfValidator/GetAbortInfo
[JSON input data] | pIAcfValidator: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort code that corresponds with the abort/error string. The abort code is 0 if there is no error condition. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred! No further information can be retrieved. |
space |


  • IAcfValidator
  • GetTariff005

IAcfValidator::GetTariff005 method |  |  | space
Retrieves the information for the "005::Fallpauschalen" tariff catalog |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAcfValidator/GetTariff005
[JSON input data] | pIAcfValidator: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrName: pbstrDBVersion: pdDBDate: plValidFrom: plValidTo: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "stringISODateValue", longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTariff005( | BSTR BSTR BSTR DATE long long VARIANT_BOOL | *pbstrTariffType, *pbstrName, *pbstrDBVersion, *pdDBDate, *plValidFrom, *plValidTo, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The tariff number '005' |
[out] BSTR | *pbstrName | The name of the tariff catalog |
[out] BSTR | *pbstrDBVersion | The version of the 005 tariff catalog |
[out] DATE | *pdDBDate | Get the issuer date of the 005 tariff catalog |
[out] long | *plValidFrom | The start date of validity of the 005 tariff catalog |
[out] long | *plValidTo | The end date of validity of the 005 tariff catalog |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IAcfValidator
  • GetTariffTMA

IAcfValidator::GetTariffTMA method |  |  | space
Retrieves the information for the "TMA::LKAAT" tariff catalog |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAcfValidator/GetTariffTMA
[JSON input data] | pIAcfValidator: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrName: pbstrDBVersion: pdDBDate: plValidFrom: plValidTo: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "stringISODateValue", longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTariffTMA( | BSTR BSTR BSTR DATE long long VARIANT_BOOL | *pbstrTariffType, *pbstrName, *pbstrDBVersion, *pdDBDate, *plValidFrom, *plValidTo, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The tariff number 'TMA' |
[out] BSTR | *pbstrName | The name of the tariff catalog |
[out] BSTR | *pbstrDBVersion | The version of the TMA tariff catalog |
[out] DATE | *pdDBDate | Get the issuer date of the TMA tariff catalog |
[out] long | *plValidFrom | The start date of validity of the TMA tariff catalog |
[out] long | *plValidTo | The end date of validity of the TMA tariff catalog |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IAcfValidator
  • Open

IAcfValidator::Open method |  |  | space
Opens the tariff catalog database |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAcfValidator/Open
[JSON input data] | pIAcfValidator: eLanguage: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Open( | LanguageType VARIANT_BOOL | eLanguage, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] LanguageType | eLanguage | The choosen language of the tariff that should be opened |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IAcfValidator
  • CreateAcfValidator

IAcfValidator::CreateAcfValidator property |  |  | space
This property has a Restful Webservice representation only! Creates an instance of the main IAcfValidator interface. To delete/invalidate this interface instance, the counterpart property PutDestructAcfValidator must be explicitly called, since the pIAcfValidator address has a global scope and is not automatically destructed. |  |  |
space
Restful webservice calling syntax |  |  |
[GET] | /baseURL/ IAcfValidator/GetCreateAcfValidator
[JSON result data] | pIAcfValidator: | longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAcfValidator
  • CreateSearch005

IAcfValidator::CreateSearch005 property | space
Create an instance of the ISearch005 interface
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetCreateSearch005?param
[param] pIAcfValidator= longValue
[JSON result data] pISearch005: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateSearch005( ISearch005 **peCreateSearch005 );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ISearch005 | **peCreateSearch005 | The instance of the ISearch005 interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ISearch005 **GetCreateSearch005(void);
space


  • IAcfValidator
  • CreateSearchTMA

IAcfValidator::CreateSearchTMA property | space
Create an instance of the ISearchTMA interface
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetCreateSearchTMA?param
[param] pIAcfValidator= longValue
[JSON result data] pISearchTMA: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateSearchTMA( ISearchTMA **peCreateSearchTMA );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ISearchTMA | **peCreateSearchTMA | The instance of the ISearchTMA interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ISearchTMA **GetCreateSearchTMA(void);
space


  • IAcfValidator
  • CreateValidate005

IAcfValidator::CreateValidate005 property | space
Create an instance of the IValidate005 interface
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetCreateValidate005?param
[param] pIAcfValidator= longValue
[JSON result data] peCreateValidate005: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateValidate005( IValidate005 **peCreateValidate005 );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IValidate005 | **peCreateValidate005 | The instance of the IValidate005 interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IValidate005 **GetCreateValidate005(void);
space


  • IAcfValidator
  • CreateValidateTMA

IAcfValidator::CreateValidateTMA property | space
Create an instance of the IValidateTMA interface
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetCreateValidateTMA?param
[param] pIAcfValidator= longValue
[JSON result data] peCreateValidateTMA: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateValidateTMA( IValidateTMA **peCreateValidateTMA );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IValidateTMA | **peCreateValidateTMA | The instance of the IValidateTMA interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IValidateTMA **GetCreateValidateTMA(void);
space


  • IAcfValidator
  • DestructAcfValidator

IAcfValidator::DestructAcfValidator property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates a main instance of the IAcfValidator interface. The counterpart property to generate a main interface instance is IAcfValidator::GetCreateAcfValidator. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IAcfValidator/PutDestructAcfValidator
[JSON input data] | pIAcfValidator: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAcfValidator
  • DestructSearch005

IAcfValidator::DestructSearch005 property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearch005 interface instance. The counterpart property to generate an ISearch005 interface instance is IAcfValidator::GetCreateSearch005. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IAcfValidator/PutDestructSearch005
[JSON input data] | pIAcfValidator: eDestructSearch005: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAcfValidator
  • DestructSearchTMA

IAcfValidator::DestructSearchTMA property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearchTMA interface instance. The counterpart property to generate an ISearch005 interface instance is IAcfValidator::GetCreateSearchTMA. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IAcfValidator/PutDestructSearchTMA
[JSON input data] | pIAcfValidator: eDestructSearchTMA: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAcfValidator
  • DestructValidate005

IAcfValidator::DestructValidate005 property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidate005 interface instance. The counterpart property to generate an ISearch005 interface instance is IAcfValidator::GetCreateValidate005. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IAcfValidator/PutDestructValidate005
[JSON input data] | pIAcfValidator: eDestructValidate005: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAcfValidator
  • DestructValidateTMA

IAcfValidator::DestructValidateTMA property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidateTMA interface instance. The counterpart property to generate an ISearch005 interface instance is IAcfValidator::GetCreateValidateTMA. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IAcfValidator/PutDestructValidateTMA
[JSON input data] | pIAcfValidator: eDestructValidateTMA: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAcfValidator
  • EnableLog

IAcfValidator::EnableLog property | space
Get and Set the log activity for the module. The default log activity is enYes.
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetEnableLog?param
[param] pIAcfValidator= longValue
[JSON result data] peEnableLog: longValue
[PUT] | /baseURL/ IAcfValidator/PutEnableLog
[JSON input data] pIAcfValidator:
eEnableLog: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | EnableLog( YesNoType *peEnableLog );
[put] HRESULT | EnableLog( YesNoType eEnableLog );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peEnableLog | Boolean that defines if the logging is enabled (enYes) or not (enNo)
[in] YesNoType | eEnableLog | Boolean that defines if the logging is enabled (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetEnableLog(void);
  • void PutEnableLog( YesNoType lEnableLog);
space


  • IAcfValidator
  • Language

IAcfValidator::Language property | space
Get and Set the language for the miscValidator module. The default language is enGerman.
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetLanguage?param
[param] pIAcfValidator= longValue
[JSON result data] peLanguage: longValue
[PUT] | /baseURL/ IAcfValidator/PutLanguage
[JSON input data] pIAcfValidator:
eLanguage: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Language( LanguageType *peLanguage );
[put] HRESULT | Language( LanguageType eLanguage );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LanguageType | *peLanguage | The language for the main interface defining the language of the error messages
[in] LanguageType | eLanguage | The language for the main interface defining the language of the error messages
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetLanguage(void);
  • void PutLanguage( LanguageType lLanguage);
space


  • IAcfValidator
  • ModuleVersion

IAcfValidator::ModuleVersion property | space
Get the version of the acfValidator module
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetModuleVersion?param
[param] pIAcfValidator= longValue
[JSON result data] pbstrModuleVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *pbstrModuleVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersion | The module version of the acfValidator module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IAcfValidator
  • ModuleVersionText

IAcfValidator::ModuleVersionText property | space
Get the textual version of the miscValidator module
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetModuleVersionText?param
[param] pIAcfValidator= longValue
[JSON result data] pbstrModuleVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *pbstrModuleVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersionText | The module version string of the acfValidator module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IAcfValidator
  • WildCard

IAcfValidator::WildCard property | space
Get and Set the match-all wildcard character for SQL queries.
You can use this property if you have imported the original tariff catalog database into another database, which uses a different wildcard character for queries. The default match-all wildcard character is the percent symbol (%). With the miscValidator module you can always formulate a query using the asterisk symbol (*) as a wildcard, as in each query string a * is replaced by the wildcard character specified by this property before being executed.
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetWildCard?param
[param] pIAcfValidator= longValue
[JSON result data] pbstrWildCard: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | WildCard( BSTR *pbstrWildCard );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrWildCard | The wildcard symbol
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetWildCard(void);
space


  • IAcfValidator
  • WildCharacter

IAcfValidator::WildCharacter property | space
Get and Set the "match any single character" wildcard character for SQL queries.
You can use this property if you have imported the original tariff catalog database into another database, which uses a different wild character for the queries. The default match-single-character wildcard character is the underscore symbol (_). With the miscValidator module you can always formulate a query using the question mark (?) as a wildcard, as in each query string a ? is replaced by the wildcard character specified by this property before execution.
space
Restful webservice calling syntax
[GET] | /baseURL/ IAcfValidator/GetWildCharacter?param
[param] pIAcfValidator= longValue
[JSON result data] pbstrWildCharacter: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | WildCharacter( BSTR *pbstrWildCharacter );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrWildCharacter | The wildcard character symbol
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetWildCharacter(void);
space


  • ISearch005

ISearch005 interface | V1.00/ 3 Aug 2025
The ISearch005 interface allows browsing and retrieval of detailed service information from the "005::Fallpauschalen" tariff catalog. A search process in the service record domain of the selected tariff catalog can be performed by code, name, or chapter respectively. The search terms may be specified in full or may include wildcards. After a successful search, all of the available information directly related to the search term is made available through the interface"s properties.

The search method (e.g. SearchGeneral) produce as a result a selection list, composed of zero or more service records. The total number of records in the list can be retrieved with the GetRecordCount method. The record pointer is initially positioned at the first entry of the selection list and the positioning methods MoveFirst, MoveLast, MoveNext, MovePrevious, PutAbsolutePosition, and GetAbsolutePosition are used to manipulate the selected record. The information related to the current record is made available through the interface"s properties like GetName for retrieving the service title.

space
space
Methods | 11 methods
GetAbortInfo | Fetches the abort/error information if there is any stored
GetAbsolutePosition | Gets the current absolute position of the record pointer in the selection list
GetRecordCount | Gets the number of ACF service records in the selection list based on the last search call
GetServices | Method for collecting all service records of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface
Initialize | Initializes the validation and clears all previously added ACF service records
MoveFirst | Moves the record pointer to the first ACF record in the selection list and makes that record the current record
MoveLast | Moves the record pointer to the last ACF record in the selection list and makes that record the current record
MoveNext | Moves the record pointer to the next ACF record in the selection list and makes that record the current record
MovePrevious | Moves the record pointer to the previous ACF record in the selection list and makes that record the current record
PutAbsolutePosition | Positions the record pointer at the specified absolute position in the ACF selection list.
SearchGeneral | The general search method for finding ACF services
space
Properties | 12 properties
[get] ChapterCode | The chapter or capitulum code the given service record belongs to
[get] ChapterName | The chapter or capitulum name the given service record belongs to
[get] Code | The ACF code of the selected service record
[put] DestructSearch005 | Destructs/invalidates this ISearch005 interface instance
[get] Interpretation | The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected service
[get] Name | The name of the selected ACF service
[get] ReferenceCode | The reference code
[get] ServiceProperties | This value defines all semantic capabilities of a service
[get] TariffType | The tariff type the selected ACF service record belongs to
[get] TP | The valid tax points (TP) of the ACF service record
[get] ValidFrom | The validity start date of the selected ACF service record
[get] ValidTo | The validity end date of the selected ACF service record
space


  • ISearch005
  • GetAbortInfo

ISearch005::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/GetAbortInfo
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch005
  • GetAbsolutePosition

ISearch005::GetAbsolutePosition method |  |  | space
Gets the current absolute position of the record pointer in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/GetAbsolutePosition
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result data] | plID: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbsolutePosition( | long VARIANT_BOOL | *plID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plID | The ID of the service record |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearch005
  • GetRecordCount

ISearch005::GetRecordCount method |  |  | space
Gets the number of ACF service records in the selection list based on the last search call |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/GetRecordCount
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result data] | plSize: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRecordCount( | long VARIANT_BOOL | *plSize, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plSize | The total number of service records included |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch005
  • GetServices

ISearch005::GetServices method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all service records of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface. The services are returned as JSON array in chunks of 200 services. Please refrain from using the positioning methods MoveFirst(), MoveNext(), etc. before calling GetServices() method. If there are more than 200 services available, just call GetServices() repeatedly until the HTTP return status is 204 == NoContent |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/GetServices
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result array] | { pbstrChapterCode: pbstrChapterName: pbstrTariffType: pbstrCode: pbstrReferenceCode: pbstrName: pbstrInterpretation: pdValidFrom: pdValidTo: pdTP: plServiceProperties: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "stringISODateValue", "stringISODateValue", doubleValue, longValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrChapterCode | The chapter or capitulum code that the current service belongs to |
[out] BSTR | *pbstrChapterName | The chapter or capitulum name that the current service belongs to |
[out] BSTR | *pbstrTariffType | The official tariff number for ACF services - this is by definition '005' |
[out] BSTR | *pbstrCode | The ACF code of the current service |
[out] BSTR | *pbstrReferenceCode | The reference code. Note that this variable is always empty as the ACF tariff does not predefine such reference codes. |
[out] BSTR | *pbstrName | The name of the current ACF service |
[out] BSTR | *pbstrInterpretation | The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected service |
[out] DATE | *pdValidFrom | The validity start date of the selected ACF service record |
[out] DATE | *pdValidTo | The validity end date of the selected ACF service record |
[out] double | *pdTP | The valid tax points (TP) of the ACF service record |
[out] long | *plServiceProperties | This value defines all semantic capabilities of a service. The value is a 32-bit integer composed from ORed values of the ServicePropertyType enumeration list. |
space |


  • ISearch005
  • Initialize

ISearch005::Initialize method |  |  | space
Initializes the validation and clears all previously added ACF service records |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/Initialize
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch005
  • MoveFirst

ISearch005::MoveFirst method |  |  | space
Moves the record pointer to the first ACF record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/MoveFirst
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. Whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearch005
  • MoveLast

ISearch005::MoveLast method |  |  | space
Moves the record pointer to the last ACF record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/MoveLast
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearch005
  • MoveNext

ISearch005::MoveNext method |  |  | space
Moves the record pointer to the next ACF record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/MoveNext
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearch005
  • MovePrevious

ISearch005::MovePrevious method |  |  | space
Moves the record pointer to the previous ACF record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/MovePrevious
[JSON input data] | pISearch005: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearch005
  • PutAbsolutePosition

ISearch005::PutAbsolutePosition method |  |  | space
Positions the record pointer at the specified absolute position in the ACF selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/PutAbsolutePosition
[JSON input data] | pISearch005: lID: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT PutAbsolutePosition( | long VARIANT_BOOL | lID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] long | lID | The ID of the service record to position to |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch005
  • SearchGeneral

ISearch005::SearchGeneral method |  |  | space
The general search method for finding ACF services. Wildcards can be used in all three fields (code, chapterCode, and name) of the SearchGeneral method, and the fields are linked via AND in the search command. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearch005/SearchGeneral
[JSON input data] | pISearch005: dDate: bstrCode: bstrName: bstrChapterCode: | longValue, //interface address variantDateValue | "stringISODateValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchGeneral( | DATE BSTR BSTR BSTR VARIANT_BOOL | dDate, bstrCode, bstrName, bstrChapterCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] BSTR | bstrCode | Query string that is used for searching in the code portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[in] BSTR | bstrName | Query string that is used for searching in the name portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[in] BSTR | bstrChapterCode | Query string that is used for searching in the chapterCode portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearch005
  • ChapterCode

ISearch005::ChapterCode property | space
The chapter or capitulum code the given service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetChapterCode?param
[param] pISearch005= longValue
[JSON result data] pbstrChapterCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ChapterCode( BSTR *pbstrChapterCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrChapterCode | The chapter or capitulum code that the current service belongs to
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetChapterCode(void);
space


  • ISearch005
  • ChapterName

ISearch005::ChapterName property | space
The chapter or capitulum name the given service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetChapterName?param
[param] pISearch005= longValue
[JSON result data] pbstrChapterName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ChapterName( BSTR *pbstrChapterName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrChapterName | The chapter or capitulum name that the current service belongs to
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetChapterName(void);
space


  • ISearch005
  • Code

ISearch005::Code property | space
The ACF code of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetCode?param
[param] pISearch005= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The ACF code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • ISearch005
  • DestructSearch005

ISearch005::DestructSearch005 property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearch005 interface instance. The counterpart property to generate an ISearch005 interface instance is IAcfValidator::GetCreateSearch005. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ISearch005/PutDestructSearch005
[JSON input data] | pISearch005: eDestructSearch005: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ISearch005
  • Interpretation

ISearch005::Interpretation property | space
The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected service
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetInterpretation?param
[param] pISearch005= longValue
[JSON result data] pbstrInterpretation: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Interpretation( BSTR *pbstrInterpretation );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrInterpretation | The service interpretation of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetInterpretation(void);
space


  • ISearch005
  • Name

ISearch005::Name property | space
The name of the selected ACF service
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetName?param
[param] pISearch005= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current ACF service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • ISearch005
  • ReferenceCode

ISearch005::ReferenceCode property | space
The reference code.

Note that this variable is always empty as the ACF tariff does not predefine such reference codes.

space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetReferenceCode?param
[param] pISearch005= longValue
[JSON result data] pbstrReferenceCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ReferenceCode( BSTR *pbstrReferenceCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrReferenceCode | The reference code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetReferenceCode(void);
space


  • ISearch005
  • ServiceProperties

ISearch005::ServiceProperties property | space
This value defines all semantic capabilities of a service.
The value is a 32-bit integer composed from ORed values of the ServicePropertyType enumeration list.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetServiceProperties?param
[param] pISearch005= longValue
[JSON result data] plServiceProperties: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ServiceProperties( long *plServiceProperties );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plServiceProperties | The ORed service properties of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetServiceProperties(void);
space


  • ISearch005
  • TariffType

ISearch005::TariffType property | space
The tariff type the selected ACF service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetTariffType?param
[param] pISearch005= longValue
[JSON result data] pbstrTariffType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TariffType( BSTR *pbstrTariffType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTariffType | The tariff type the selected ACF service record - always return '005'
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTariffType(void);
space


  • ISearch005
  • TP

ISearch005::TP property | space
The valid tax points (TP) of the ACF service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetTP?param
[param] pISearch005= longValue
[JSON result data] pdTP: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP( double *pdTP );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP | The tax points (TP) of the current ACF service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP(void);
space


  • ISearch005
  • ValidFrom

ISearch005::ValidFrom property | space
The validity start date of the selected ACF service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetValidFrom?param
[param] pISearch005= longValue
[JSON result data] pdValidFrom: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidFrom( DATE *pdValidFrom );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidFrom | The validity start of the current ACF service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidFrom(void);
space


  • ISearch005
  • ValidTo

ISearch005::ValidTo property | space
The validity end date of the selected ACF service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearch005/GetValidTo?param
[param] pISearch005= longValue
[JSON result data] pdValidTo: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidTo( DATE *pdValidTo );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidTo | The validity end of the current ACF service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidTo(void);
space


  • ISearchTMA

ISearchTMA interface | V1.00/ 3 Aug 2025
The ISearchTMA interface allows browsing and retrieval of detailed service information from the "TMA::LKAAT" tariff catalog. A search process in the service record domain of the selected tariff catalog can be performed by code, name, or chapter respectively. The search terms may be specified in full or may include wildcards. After a successful search, all of the available information directly related to the search term is made available through the interface"s properties.

The search method (e.g. SearchGeneral) produce as a result a selection list, composed of zero or more service records. The total number of records in the list can be retrieved with the GetRecordCount method. The record pointer is initially positioned at the first entry of the selection list and the positioning methods MoveFirst, MoveLast, MoveNext, MovePrevious, PutAbsolutePosition, and GetAbsolutePosition are used to manipulate the selected record. The information related to the current record is made available through the interface"s properties like GetName for retrieving the service title.

There are further search methods that are specific for specialized task like search for main trigger services (service is of type P(OR) and/or P(notOR), or to search for an ICD code usable in a certain capitulum.

space
space
Methods | 18 methods
FindOptServiceTree | This is one of the most essential methods that brings you back an optional static decision tree table when starting with an ACFBase element and at least one main trigger service (P)
GetAbortInfo | Fetches the abort/error information if there is any stored
GetAbsolutePosition | Gets the current absolute position of the record pointer in the selection list
GetFirstOptServiceTree | This is the first iterator over the results of the FindOptServiceTree method
GetNextOptServiceTree | This is the next iterator over the results of theFindOptServiceTree method
GetOptServicesTree | Method for collecting all optional services in one call without the necessity to call the iterator pair ISearchTMA::GetFirstOptServiceTree / ISearchTMA::GetNextOptServiceTree
GetRecordCount | Gets the number of TMA service records in the selection list based on the last search call
GetServices | Method for collecting all service records of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface
Initialize | Initializes the validation and clears all previously added ACF service records
MoveFirst | Moves the record pointer to the first TMA record in the selection list and makes that record the current record
MoveLast | Moves the record pointer to the last TMA record in the selection list and makes that record the current record
MoveNext | Moves the record pointer to the next TMA record in the selection list and makes that record the current record
MovePrevious | Moves the record pointer to the previous TMA record in the selection list and makes that record the current record
PutAbsolutePosition | Positions the record pointer at the specified absolute position in the TMA selection list.
Search4ICD | The Search4ICD method is used to search for ICD-10 codes within the grouper's permitted and used ICD space
Search4Slaves | The specialized Search4Slaves method is used to search for all TMA slave services of a given TMA master service
Search4Trigger | The specialized Search4Trigger method is used to search for TMA services of type { P(OR) | P(notOR) | P }
SearchGeneral | The general search method for finding TMA services
space
Properties | 12 properties
[get] ChapterCode | The chapter or capitulum code the given service record belongs to
[get] ChapterName | The chapter or capitulum name the given service record belongs to
[get] Code | The TMA code of the selected service record
[put] DestructSearchTMA | Destructs/invalidates this ISearchTMA interface instance
[get] Interpretation | The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected service
[get] Name | The name of the selected TMA service or ICD code
[get] ReferenceCode | The reference code
[get] ServiceProperties | This value defines all semantic capabilities of a service
[get] TariffType | The tariff type the selected TMA service record belongs to
[get] TMAType | The characterization/type affiliation of the TMA service - the possible value range is predefined in TMAType.
[get] ValidFrom | The validity start date of the selected TMA service record
[get] ValidTo | The validity end date of the selected TMA service record
space


  • ISearchTMA
  • FindOptServiceTree

ISearchTMA::FindOptServiceTree method | space
This is one of the most essential methods that brings you back an optional static decision tree table when starting with an ACFBase element and at least one main trigger service (P).

Please study the description of bstrACFStatusList for a in-depth knowledge of the outcome of this method. Furthermore an example of the output is given in the decsription of the iterator pair GetFirstOptServiceTree / GetNextOptServiceTree.

Cavete: due to technical circumstances, "7680664950014 = SPINRAZA Inj Sol 12 mg/5ml" is never proposed as a possible optional service!

space
Restful webservice calling syntax
[POST] | /baseURL/ ISearchTMA/FindOptServiceTree
[JSON input data] pISearchTMA:
pIValidateTMA:
dDate:
lSessionNumber: 		longValue, //interface address
longValue,
variantDateValue | "stringISODateValue",
longValue
[JSON result data] pbstrACFStatusList:
pbStatus: 		"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT FindOptServiceTree( IValidateTMA
DATE
long
BSTR
VARIANT_BOOL 		*pIValidateTMA,
dDate,
lSessionNumber,
*pbstrACFStatusList,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] IValidateTMA | *pIValidateTMA | The IValidateTMA interface instance that holds at least one trigger service and the corresponding, defined ACFBase element, for which a decision tree walk should be performed.
[in] DATE | dDate | The date of the service application
[in] long | lSessionNumber | The unique session number to which the services and the global data (ICD and patient data) are coupled.
[out] BSTR *pbstrACFStatusList This is a hash separated list of possibly reachable ACF services formatted as sessionNumber(ACFCode1#ACFCode2#...#ACFCoden) - e.g. 35(C08.26A#C08.26B#C08.26C) or 40(C02.30D) or 50(ERR_NO.amP) ).
Please note that the latter example shows a non-grouping result - the iterator pair GetFirstOptServiceTree / GetNextOptServiceTree will be empty in that case!
The middle result in the list above shows that the given trigger service is directly grouped to the given ACF service without optional TMA services - - the iterator pair GetFirstOptServiceTree / GetNextOptServiceTree will be empty in that case!
The first case shows that various ACF services can be reached dependent on the list returned by the iterator pair GetFirstOptServiceTree / GetNextOptServiceTree.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearchTMA
  • GetAbortInfo

ISearchTMA::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/GetAbortInfo
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearchTMA
  • GetAbsolutePosition

ISearchTMA::GetAbsolutePosition method |  |  | space
Gets the current absolute position of the record pointer in the selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/GetAbsolutePosition
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result data] | plID: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbsolutePosition( | long VARIANT_BOOL | *plID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plID | The ID of the service record |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearchTMA
  • GetFirstOptServiceTree

ISearchTMA::GetFirstOptServiceTree method | space
This is the first iterator over the results of the FindOptServiceTree method.

VARIANT_FALSE is returned if there are no optional services available.

Below is an example output of a FindOptServiceTree run, that you can consult for an understanding of the meaning of the variables:

DecisionID | DecisionYesID | DecisionNoID | ChoiceSet | Qty | Side | Code | Name
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z001 | Naht eines Meniskus
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z004 | Retinakulumspaltung ...
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z007 | Versorgung bei Osteo...
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z008 | Versorgung Ruptur...
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z009 | Versorgung Tibiakopf...
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z014 | Retinakulumnaht
739485.183 | C08.26B | C08.26C | choice187 | 1 | N | C08.MA.Z002 | Resektion einer Gelenk...
739485.183 | C08.26B | C08.26C | choice187 | 1 | N | C08.MA.Z006 | Mikrofrakturierung oder...
739485.183 | C08.26B | C08.26C | choice187 | 1 | N | C08.MA.Z010 | Entfernung des Osteo...
739485.183 | C08.26B | C08.26C | choice187 | 1 | N | C08.MA.Z015 | Anlegen einer Spül...
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearchTMA/GetFirstOptServiceTree
[JSON input data] pISearchTMA: longValue, //interface address
[JSON result data] pbstrDecisionID:
pbstrDecisionYesID:
peDecisionYesIsACF:
pbstrDecisionNoID:
peDecisionNoIsACF:
pbstrCode:
pbstrName:
pdMinQuantity:
peMinSide:
pbstrChoiceSet:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
longValue,
"utf8StringValue",
longValue,
"utf8StringValue",
"utf8StringValue",
doubleValue,
longValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetFirstOptServiceTree( BSTR
BSTR
YesNoType
BSTR
YesNoType
BSTR
BSTR
double
SideType
BSTR
VARIANT_BOOL 		*pbstrDecisionID,
*pbstrDecisionYesID,
*peDecisionYesIsACF,
*pbstrDecisionNoID,
*peDecisionNoIsACF,
*pbstrCode,
*pbstrName,
*pdMinQuantity,
*peMinSide,
*pbstrChoiceSet,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR *pbstrDecisionID This is a fictional ID of a decision node representing one optional TMA service with requested quantity and side dependency. The supplied bstrChoiceSet is a fictional choice set name, collecting a set of TMA services. At least one element of the set must be selected to qualify for the YES path.

If there are more than 1 distinct choice set names on a certain decision node, than these sets are AND connected, meaning that at least one element of each set must be selected to qualify for the YES path.

[out] BSTR *pbstrDecisionYesID This is the fictional ID of the next decision node, if the YES path is selected.

If the Boolean variable eDecisionYesIsACF=enYes than bstrDecisionYesID represents a terminal ACF service code. If eDecisionYesIsACF=enNo you have to go to this fictional ID and start there with a decision process.

[out] YesNoType | *peDecisionYesIsACF | A Boolean variable defining the bstrDecisionYesID ID as terminal ACF service (=enYes) or as another fictional node ID (=enNo).
[out] BSTR *pbstrDecisionNoID This is the fictional ID of the next decision node, if the NO path is selected.

If the Boolean variable eDecisionNoIsACF=enYes than bstrDecisionNoID represents a terminal ACF service code. If eDecisionNoIsACF=enNo you have to go to this fictional ID and start there with a decision process.

[out] YesNoType | *peDecisionNoIsACF | A Boolean variable defining the bstrDecisionNoID ID as terminal ACF service (=enYes) or as another fictional node ID (=enNo).
[out] BSTR | *pbstrCode | The code of a TMA service in the set of services with the same bstrChoiceSet
[out] BSTR | *pbstrName | The name of a TMA service in the set of services with the same bstrChoiceSet
[out] double | *pdMinQuantity | This is the minimal quantity of the given TMA code to qualify for fulfilled service
[out] SideType | *peMinSide | This is the minimal side dependency of the given TMA code to qualify for fulfilled service
[out] BSTR | *pbstrChoiceSet | The supplied bstrChoiceSet is a fictional choice set name, collecting a set of TMA services. At least one element of the set must be selected to qualify for the YES path.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearchTMA
  • GetNextOptServiceTree

ISearchTMA::GetNextOptServiceTree method | space
This is the next iterator over the results of theFindOptServiceTree method.

VARIANT_FALSE is returned if there are no optional services available.

Below is an example output of a FindOptServiceTree run, that you can consult for an understanding of the meaning of the variables:

DecisionID | DecisionYesID | DecisionNoID | ChoiceSet | Qty | Side | Code | Name
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z001 | Naht eines Meniskus
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z004 | Retinakulumspaltung ...
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z007 | Versorgung bei Osteo...
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z008 | Versorgung Ruptur...
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z009 | Versorgung Tibiakopf...
739483.180 | C08.26A | 739485.183 | choice184 | 1 | N | C08.MA.Z014 | Retinakulumnaht
739485.183 | C08.26B | C08.26C | choice187 | 1 | N | C08.MA.Z002 | Resektion einer Gelenk...
739485.183 | C08.26B | C08.26C | choice187 | 1 | N | C08.MA.Z006 | Mikrofrakturierung oder...
739485.183 | C08.26B | C08.26C | choice187 | 1 | N | C08.MA.Z010 | Entfernung des Osteo...
739485.183 | C08.26B | C08.26C | choice187 | 1 | N | C08.MA.Z015 | Anlegen einer Spül...
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearchTMA/GetNextOptServiceTree
[JSON input data] pISearchTMA: longValue, //interface address
[JSON result data] pbstrDecisionID:
pbstrDecisionYesID:
peDecisionYesIsACF:
pbstrDecisionNoID:
peDecisionNoIsACF:
pbstrCode:
pbstrName:
pdMinQuantity:
peMinSide:
pbstrChoiceSet:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
longValue,
"utf8StringValue",
longValue,
"utf8StringValue",
"utf8StringValue",
doubleValue,
longValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetNextOptServiceTree( BSTR
BSTR
YesNoType
BSTR
YesNoType
BSTR
BSTR
double
SideType
BSTR
VARIANT_BOOL 		*pbstrDecisionID,
*pbstrDecisionYesID,
*peDecisionYesIsACF,
*pbstrDecisionNoID,
*peDecisionNoIsACF,
*pbstrCode,
*pbstrName,
*pdMinQuantity,
*peMinSide,
*pbstrChoiceSet,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR *pbstrDecisionID This is a fictional ID of a decision node representing one optional TMA service with requested quantity and side dependency. The supplied bstrChoiceSet is a fictional choice set name, collecting a set of TMA services. At least one element of the set must be selected to qualify for the YES path.

If there are more than 1 distinct choice set names on a certain decision node, than these sets are AND connected, meaning that at least one element of each set must be selected to qualify for the YES path.

[out] BSTR *pbstrDecisionYesID This is the fictional ID of the next decision node, if the YES path is selected.

If the Boolean variable eDecisionYesIsACF=enYes than bstrDecisionYesID represents a terminal ACF service code. If eDecisionYesIsACF=enNo you have to go to this fictional ID and start there with a decision process.

[out] YesNoType | *peDecisionYesIsACF | A Boolean variable defining the bstrDecisionYesID ID as terminal ACF service (=enYes) or as another fictional node ID (=enNo).
[out] BSTR *pbstrDecisionNoID This is the fictional ID of the next decision node, if the NO path is selected.

If the Boolean variable eDecisionNoIsACF=enYes than bstrDecisionNoID represents a terminal ACF service code. If eDecisionNoIsACF=enNo you have to go to this fictional ID and start there with a decision process.

[out] YesNoType | *peDecisionNoIsACF | A Boolean variable defining the bstrDecisionNoID ID as terminal ACF service (=enYes) or as another fictional node ID (=enNo).
[out] BSTR | *pbstrCode | The code of a TMA service in the set of services with the same bstrChoiceSet
[out] BSTR | *pbstrName | The name of a TMA service in the set of services with the same bstrChoiceSet
[out] double | *pdMinQuantity | This is the minimal quantity of the given TMA code to qualify for fulfilled service
[out] SideType | *peMinSide | This is the minimal side dependency of the given TMA code to qualify for fulfilled service
[out] BSTR | *pbstrChoiceSet | The supplied bstrChoiceSet is a fictional choice set name, collecting a set of TMA services. At least one element of the set must be selected to qualify for the YES path.
[out,retval] VARIANT_BOOL *pbStatus Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name).
In the later case check for possible errors with the GetAbortInfo method.
space


  • ISearchTMA
  • GetOptServicesTree

ISearchTMA::GetOptServicesTree method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all optional services in one call without the necessity to call the iterator pair ISearchTMA::GetFirstOptServiceTree / ISearchTMA::GetNextOptServiceTree. The service records are returned as JSON array however large that array size might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/GetOptServicesTree
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result array] | { pbstrDecisionID: pbstrDecisionYesID: peDecisionYesIsACF: pbstrDecisionNoID: peDecisionNoIsACF: pbstrCode: pbstrName: pdMinQuantity: peMinSide: pbstrChoiceSet: pbStatus: | "utf8StringValue", "utf8StringValue", longValue, "utf8StringValue", longValue, "utf8StringValue", "utf8StringValue", doubleValue, longValue, "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrDecisionID | This is a fictional ID of a decision node representing one optional TMA service with requested quantity and side dependency. The supplied bstrChoiceSet is a fictional choice set name, collecting a set of TMA services. At least one element of the set must be selected to qualify for the YES path. If there are more than 1 distinct choice set names on a certain decision node, than these sets are AND connected, meaning that at least one element of each set must be selected to qualify for the YES path. |
[out] BSTR | *pbstrDecisionYesID | This is the fictional ID of the next decision node, if the YES path is selected. If the Boolean variable eDecisionYesIsACF=enYes than bstrDecisionYesID represents a terminal ACF service code. If eDecisionYesIsACF=enNo you have to go to this fictional ID and start there with a decision process. |
[out] YesNoType | *peDecisionYesIsACF | A Boolean variable defining the bstrDecisionYesID ID as terminal ACF service (=enYes) or as another fictional node ID (=enNo). |
[out] BSTR | *pbstrDecisionNoID | This is the fictional ID of the next decision node, if the NO path is selected. If the Boolean variable eDecisionNoIsACF=enYes than bstrDecisionNoID represents a terminal ACF service code. If eDecisionNoIsACF=enNo you have to go to this fictional ID and start there with a decision process. |
[out] YesNoType | *peDecisionNoIsACF | A Boolean variable defining the bstrDecisionNoID ID as terminal ACF service (=enYes) or as another fictional node ID (=enNo). |
[out] BSTR | *pbstrCode | The code of a TMA service in the set of services with the same bstrChoiceSet |
[out] BSTR | *pbstrName | The name of a TMA service in the set of services with the same bstrChoiceSet |
[out] double | *pdMinQuantity | This is the minimal quantity of the given TMA code to qualify for fulfilled service |
[out] SideType | *peMinSide | This is the minimal side dependency of the given TMA code to qualify for fulfilled service |
[out] BSTR | *pbstrChoiceSet | The supplied bstrChoiceSet is a fictional choice set name, collecting a set of TMA services. At least one element of the set must be selected to qualify for the YES path. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • ISearchTMA
  • GetRecordCount

ISearchTMA::GetRecordCount method |  |  | space
Gets the number of TMA service records in the selection list based on the last search call |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/GetRecordCount
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result data] | plSize: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRecordCount( | long VARIANT_BOOL | *plSize, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plSize | The total number of service records included |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearchTMA
  • GetServices

ISearchTMA::GetServices method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all service records of the resulting search space in one call without the necessity to call the record positioning methods and the appropriate properties of this interface. The services are returned as JSON array in chunks of 200 services. Please refrain from using the positioning methods MoveFirst(), MoveNext(), etc. before calling GetServices() method. If there are more than 200 services available, just call GetServices() repeatedly until the HTTP return status is 204 == NoContent |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/GetServices
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result array] | { pbstrChapterCode: pbstrChapterName: pbstrTariffType: pbstrCode: pbstrReferenceCode: pbstrName: pbstrInterpretation: pdValidFrom: pdValidTo: plServiceProperties: peTMAType: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "stringISODateValue", "stringISODateValue", longValue, longValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrChapterCode | The chapter or capitulum code that the current service belongs to |
[out] BSTR | *pbstrChapterName | The chapter or capitulum name that the current service belongs to |
[out] BSTR | *pbstrTariffType | The official tariff number for TMA services - this is by definition 'TMA' |
[out] BSTR | *pbstrCode | The TMA code of the current service |
[out] BSTR | *pbstrReferenceCode | The reference code. Note that this variable is always empty as the ACF tariff does not predefine such reference codes. |
[out] BSTR | *pbstrName | The name of the current TMA service |
[out] BSTR | *pbstrInterpretation | The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected service |
[out] DATE | *pdValidFrom | The validity start date of the selected TMA service record |
[out] DATE | *pdValidTo | The validity end date of the selected TMA service record |
[out] long | *plServiceProperties | This value defines all semantic capabilities of a service. The value is a 32-bit integer composed from ORed values of the ServicePropertyType enumeration list. |
[out] TMAType | *peTMAType | The characterization/type affiliation of the TMA service - the possible value range is predefined in TMAType. |
space |


  • ISearchTMA
  • Initialize

ISearchTMA::Initialize method |  |  | space
Initializes the validation and clears all previously added ACF service records |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/Initialize
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearchTMA
  • MoveFirst

ISearchTMA::MoveFirst method |  |  | space
Moves the record pointer to the first TMA record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/MoveFirst
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveFirst( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearchTMA
  • MoveLast

ISearchTMA::MoveLast method |  |  | space
Moves the record pointer to the last TMA record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/MoveLast
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveLast( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearchTMA
  • MoveNext

ISearchTMA::MoveNext method |  |  | space
Moves the record pointer to the next TMA record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/MoveNext
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MoveNext( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearchTMA
  • MovePrevious

ISearchTMA::MovePrevious method |  |  | space
Moves the record pointer to the previous TMA record in the selection list and makes that record the current record. All property functions act upon and return data from that current record If the action could not be performed or the selection list is empty than S_FALSE will be returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/MovePrevious
[JSON input data] | pISearchTMA: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT MovePrevious( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return the status of the method. If pbStatus is VARIANT_TRUE than all is OK. whereas VARIANT_FALSE means that the action could no be completed due to an "end_of_data" message or an error situation. Call GetAbortInfo to check for possible errors. |
space |


  • ISearchTMA
  • PutAbsolutePosition

ISearchTMA::PutAbsolutePosition method |  |  | space
Positions the record pointer at the specified absolute position in the TMA selection list. This method can be useful for implementing virtual selection lists. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/PutAbsolutePosition
[JSON input data] | pISearchTMA: lID: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT PutAbsolutePosition( | long VARIANT_BOOL | lID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] long | lID | The ID of the service record to position to |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearchTMA
  • Search4ICD

ISearchTMA::Search4ICD method |  |  | space
The Search4ICD method is used to search for ICD-10 codes within the grouper's permitted and used ICD space. Consequently, if an ICD code outside this permitted set is used in IValidateTMA::AddACFBase, it is rejected Since the ICD code set has a large search space, it is advisable to first search for a main trigger service and then include the corresponding chapter affiliation in the ICD code search. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/Search4ICD
[JSON input data] | pISearchTMA: dDate: bstrCode: bstrName: bstrChapterCode: | longValue, //interface address variantDateValue | "stringISODateValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Search4ICD( | DATE BSTR BSTR BSTR VARIANT_BOOL | dDate, bstrCode, bstrName, bstrChapterCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] BSTR | bstrCode | Query string that is used for searching in the code portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[in] BSTR | bstrName | Query string that is used for searching in the name portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[in] BSTR | bstrChapterCode | Query string that is used for searching in the chapterCode portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearchTMA
  • Search4Slaves

ISearchTMA::Search4Slaves method |  |  | space
The specialized Search4Slaves method is used to search for all TMA slave services of a given TMA master service. Do not use wildcards in the masterCode field. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/Search4Slaves
[JSON input data] | pISearchTMA: dDate: bstrMasterCode: | longValue, //interface address variantDateValue | "stringISODateValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Search4Slaves( | DATE BSTR VARIANT_BOOL | dDate, bstrMasterCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] BSTR | bstrMasterCode | The master code for which all slaves are returned. Do not use wildcards in the masterCode field. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearchTMA
  • Search4Trigger

ISearchTMA::Search4Trigger method | space
The specialized Search4Trigger method is used to search for TMA services of type { P(OR) | P(notOR) | P }.
Wildcards can be used in all three fields (code, chapterCode, and name) of the Search4Trigger method, and the fields are linked via AND in the search command.
space
Restful webservice calling syntax
[POST] | /baseURL/ ISearchTMA/Search4Trigger
[JSON input data] pISearchTMA:
dDate:
lTMAFilter:
bstrCode:
bstrName:
bstrChapterCode: 		longValue, //interface address
variantDateValue | "stringISODateValue",
longValue,
"utf8StringValue",
"utf8StringValue",
"utf8StringValue"
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT Search4Trigger( DATE
long
BSTR
BSTR
BSTR
VARIANT_BOOL 		dDate,
lTMAFilter,
bstrCode,
bstrName,
bstrChapterCode,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] DATE dDate The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date!
Supply a DATE <= 0 to turn off the date range check!
[in] long lTMAFilter The following filter switches are allowed here:
  • lTMAFilter <= 1 (enTMATypeIsPOR)
  • lTMAFilter == 2 (enTMATypeIsPNotOR)
  • lTMAFilter >= 3 (enTMATypeIsP)
[in] BSTR bstrCode Query string that is used for searching in the code portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards).

The code, chapterCode and name fields are coupled with AND in the SQL Select command.

[in] BSTR bstrName Query string that is used for searching in the name portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards).

The code, chapterCode and name fields are coupled with AND in the SQL Select command.

[in] BSTR bstrChapterCode Query string that is used for searching in the chapterCode portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards).

The code, chapterCode and name fields are coupled with AND in the SQL Select command.

[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value.
space


  • ISearchTMA
  • SearchGeneral

ISearchTMA::SearchGeneral method |  |  | space
The general search method for finding TMA services. Wildcards can be used in all three fields (code, chapterCode, and name) of the SearchGeneral method, and the fields are linked via AND in the search command. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ ISearchTMA/SearchGeneral
[JSON input data] | pISearchTMA: dDate: eTMAType: eOnlyGrouperRelevant: bstrCode: bstrName: bstrChapterCode: | longValue, //interface address variantDateValue | "stringISODateValue", longValue, longValue, "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SearchGeneral( | DATE TMAType YesNoType BSTR BSTR BSTR VARIANT_BOOL | dDate, eTMAType, eOnlyGrouperRelevant, bstrCode, bstrName, bstrChapterCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] DATE | dDate | The date to use for the query. Valid (and returned) records must have a validity date range that does include the given date! Supply a DATE <= 0 to turn off the date range check! |
[in] TMAType | eTMAType | Restriction of the search space to the type of TMA services (cf. value space of TMAType enumeration). eTMAType = enTMATypeAny define no restriction upon the TMA type! |
[in] YesNoType | eOnlyGrouperRelevant | Boolean that restricts the search space to grouperRelevant services (enYes) or defines no restriction in this regard (enNo). |
[in] BSTR | bstrCode | Query string that is used for searching in the code portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[in] BSTR | bstrName | Query string that is used for searching in the name portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[in] BSTR | bstrChapterCode | Query string that is used for searching in the chapterCode portion of the tariff catalog (cf. properties WildCard and WildCharacter for using wildcards). The code, chapterCode and name fields are coupled with AND in the SQL Select command. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • ISearchTMA
  • ChapterCode

ISearchTMA::ChapterCode property | space
The chapter or capitulum code the given service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetChapterCode?param
[param] pISearchTMA= longValue
[JSON result data] pbstrChapterCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ChapterCode( BSTR *pbstrChapterCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrChapterCode | The chapter or capitulum code that the current service belongs to
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetChapterCode(void);
space


  • ISearchTMA
  • ChapterName

ISearchTMA::ChapterName property | space
The chapter or capitulum name the given service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetChapterName?param
[param] pISearchTMA= longValue
[JSON result data] pbstrChapterName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ChapterName( BSTR *pbstrChapterName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrChapterName | The chapter or capitulum name that the current service belongs to
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetChapterName(void);
space


  • ISearchTMA
  • Code

ISearchTMA::Code property | space
The TMA code of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetCode?param
[param] pISearchTMA= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The TMA code of the selected service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • ISearchTMA
  • DestructSearchTMA

ISearchTMA::DestructSearchTMA property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this ISearchTMA interface instance. The counterpart property to generate an ISearch005 interface instance is IAcfValidator::GetCreateSearchTMA. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ ISearchTMA/PutDestructSearchTMA
[JSON input data] | pISearchTMA: eDestructSearchTMA: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • ISearchTMA
  • Interpretation

ISearchTMA::Interpretation property | space
The interpretation (exclusion and inclusion remarks, rules, comments and the like) of the selected service
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetInterpretation?param
[param] pISearchTMA= longValue
[JSON result data] pbstrInterpretation: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Interpretation( BSTR *pbstrInterpretation );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrInterpretation | The service interpretation of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetInterpretation(void);
space


  • ISearchTMA
  • Name

ISearchTMA::Name property | space
The name of the selected TMA service or ICD code
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetName?param
[param] pISearchTMA= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current TMA service or ICD code
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • ISearchTMA
  • ReferenceCode

ISearchTMA::ReferenceCode property | space
The reference code.

Note that this is the output of a search process and therefore this variable is always empty as the LKAAT tariff does not predefine such reference codes.

space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetReferenceCode?param
[param] pISearchTMA= longValue
[JSON result data] pbstrReferenceCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ReferenceCode( BSTR *pbstrReferenceCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrReferenceCode | The reference code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetReferenceCode(void);
space


  • ISearchTMA
  • ServiceProperties

ISearchTMA::ServiceProperties property | space
This value defines all semantic capabilities of a service.
The value is a 32-bit integer composed from ORed values of the ServicePropertyType enumeration list.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetServiceProperties?param
[param] pISearchTMA= longValue
[JSON result data] plServiceProperties: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ServiceProperties( long *plServiceProperties );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plServiceProperties | The ORed service properties of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetServiceProperties(void);
space


  • ISearchTMA
  • TariffType

ISearchTMA::TariffType property | space
The tariff type the selected TMA service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetTariffType?param
[param] pISearchTMA= longValue
[JSON result data] pbstrTariffType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TariffType( BSTR *pbstrTariffType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTariffType | The tariff type the selected TMA service record - always return 'TMA'
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTariffType(void);
space


  • ISearchTMA
  • TMAType

ISearchTMA::TMAType property | space
The characterization/type affiliation of the TMA service - the possible value range is predefined in TMAType.
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetTMAType?param
[param] pISearchTMA= longValue
[JSON result data] peTMAType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TMAType( TMAType *peTMAType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] TMAType | *peTMAType | The TMAType value
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • TMAType *GetTMAType(void);
space


  • ISearchTMA
  • ValidFrom

ISearchTMA::ValidFrom property | space
The validity start date of the selected TMA service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetValidFrom?param
[param] pISearchTMA= longValue
[JSON result data] pdValidFrom: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidFrom( DATE *pdValidFrom );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidFrom | The validity start of the current TMA service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidFrom(void);
space


  • ISearchTMA
  • ValidTo

ISearchTMA::ValidTo property | space
The validity end date of the selected TMA service record
space
Restful webservice calling syntax
[GET] | /baseURL/ ISearchTMA/GetValidTo?param
[param] pISearchTMA= longValue
[JSON result data] pdValidTo: "stringISODateValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ValidTo( DATE *pdValidTo );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] DATE | *pdValidTo | The validity end of the current TMA service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • DATE *GetValidTo(void);
space


  • IValidate005

IValidate005 interface |  | V1.00/ 3 Aug 2025
The IValidate005 interface allows for the input and validation of supplied service data. The validation checks whether the data conforms to the rule set of the selected service. There will be a rejection of a supplied service if it is in conflict with another service or with some inherent rules. All data and the calculated amount of a service can be retrieved can be retrieved with the interface"s properties. Finally, after all service records have been added the finalize methods starts all finale rule checks and returns the number of Ambulatory Case Flatrates and the summed up amount over all services. |  | space
space
Methods |  | 7 methods
AddService | Adds a new ACF service to the list of services which will be validated against all previously added services of the same session |
Finalize | Validate all ACF services by running the "late binding" rules and than finalizes all records added so far and finally calculates the total amount in CHF over all ACF service amounts |
GetAbortInfo | Fetches the abort/error information if there is any stored |
GetFirstService | Gets the first ACF service from the list of services |
GetNextService | Gets the next ACF service from the list of services |
GetServices | Method for collecting all ACF services in one call without the necessity to call the iterator pair IValidate005::GetFirstService / IValidate005::GetNextService |
Initialize | Initializes the validation and clears all previously added TMA service records |
space
Properties |  | 15 properties
[get] Amount | The amount of the service in CHF calculated by the equation Amount = (ExternalFactor * Quantity * TP * TPValue). |
[get] Code | The ACF code of the selected service record |
[get] Date | The date of the service provision |
[put] DestructValidate005 | Destructs/invalidates this IValidate005 interface instance |
[get] ExternalFactor | The external factor of the ACF service as defined by OAAT |
[get] Hook | The hook of the selected service (external ID) |
[get] IgnoreValidate | Flag indicating whether the validation was ignored or not |
[get] Name | The name of the selected ACF service |
[get] Quantity | The quantity of the ACF service record |
[get] ReferenceCode | The reference code |
[get] SessionNumber | The session number or patient contact ID |
[get] SideType | The side dependency of the ACF service |
[get] TariffType | The tariff type the selected ACF service record belongs to |
[get] TP | The valid tax points (TP) of the ACF service record |
[get] TPValue | The tax point value of the ACF service as defined by the cantons |
space |


  • IValidate005
  • AddService

IValidate005::AddService method | space
Adds a new ACF service to the list of services which will be validated against all previously added services of the same session. If the code supplied passes all validations a VARIANT_TRUE value is returned. If the code was not accepted VARIANT_FALSE is returned and the variable plStatus contains the error code.
space
Restful webservice calling syntax
[POST] | /baseURL/ IValidate005/AddService
[JSON input data] pIValidate005:
bstrCode:
bstrReferenceCode:
dQuantity:
lSessionNumber:
dDate:
eSide:
dTP:
dTPValue:
dExternalFactor:
eIgnoreValidate:
lHook: 		longValue, //interface address
"utf8StringValue",
"utf8StringValue",
doubleValue,
longValue,
variantDateValue | "stringISODateValue",
longValue,
doubleValue,
doubleValue,
doubleValue,
longValue,
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT AddService( BSTR
BSTR
double
long
DATE
SideType
double
double
double
YesNoType
long
VARIANT_BOOL 		bstrCode,
bstrReferenceCode,
dQuantity,
lSessionNumber,
dDate,
eSide,
dTP,
dTPValue,
dExternalFactor,
eIgnoreValidate,
lHook,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrCode | Code of the service
[in] BSTR bstrReferenceCode The reference code of the service.

Since the ACF tariff does not have any reference codes, this variable can be used as an ICD-10 container. In other words, if a code is used here, it will be interpreted as an ICD-10 code. When invoicing, you will not need to input the ICD10 code by other means.

[in] double | dQuantity | Quantity of the service
[in] long lSessionNumber The session number or patient contact ID.

Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data).

[in] DATE | dDate | Date of the service to ensure that the validity date range is obeyed
[in] SideType | eSide | The side for which the service is applied or enSideNone if there is noSideDependeny
[in] double dTP Tax point of the service.
If enIgnoreValidate=enNo and dTP=0 then the tax point is auto-expanded to the correct TP by the validator.
If the upper bound of a variable TP service is undefined than TP is set 0 in the auto-expansion!
[in] double dTPValue Tax point value of the service
Please note that there is no internal database for the various tax point values. Therefore, there is no auto-expansion of the TPV possible.
[in] double | dExternalFactor | The external factor is used and defined by OAAT as modulation factor within its cost neutrality project.
[in] YesNoType eIgnoreValidate Flag indicating whether the validation should be ignored or not.
To turn off the validation might be useful in the situation when a service should be added even if the validation failed due to a special agreement with the insurance or patient.
[in] long | lHook | The external hook, that was provided in the AddService call. The lHook ID primarily serves to identify this service when the services are read back.
[out,retval] VARIANT_BOOL *pbStatus The principal validation status
  • =0 is returned for success
  • >0 indicates that a validation rule was not fulfilled - the service is not added. Use the GetAbortInfo to get an error description string.
  • <0 indicates a severe principal COM automation error - the service is not added. Use the GetAbortInfo to get an error description string.
space


  • IValidate005
  • Finalize

IValidate005::Finalize method |  |  | space
Validate all ACF services by running the "late binding" rules and than finalizes all records added so far and finally calculates the total amount in CHF over all ACF service amounts. This method is the counterpart to the Initialize method. Note, this method should be called after all data have been set in the IValidate005:AddService method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate005/Finalize
[JSON input data] | pIValidate005: | longValue, //interface address
[JSON result data] | plNumACF: pdTotalAmount: pbStatus: | longValue, doubleValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Finalize( | long double VARIANT_BOOL | *plNumACF, *pdTotalAmount, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plNumACF | The number of ACF services having a distinct SessionNumber |
[out] double | *pdTotalAmount | The total amount in CHF over all ACF service amounts |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate005
  • GetAbortInfo

IValidate005::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate005/GetAbortInfo
[JSON input data] | pIValidate005: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidate005
  • GetFirstService

IValidate005::GetFirstService method |  |  | space
Gets the first ACF service from the list of services. VARIANT_FALSE is returned if the end of the service list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate005/GetFirstService
[JSON input data] | pIValidate005: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrCode: pbstrReferenceCode: pdQuantity: plSessionNumber: pdDate: peSide: pbstrName: pdTP: pdTPValue: pdExternalFactor: pdAmount: plHook: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, longValue, "stringISODateValue", longValue, "utf8StringValue", doubleValue, doubleValue, doubleValue, doubleValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstService( | BSTR BSTR BSTR double long DATE SideType BSTR double double double double long VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrReferenceCode, *pdQuantity, *plSessionNumber, *pdDate, *peSide, *pbstrName, *pdTP, *pdTPValue, *pdExternalFactor, *pdAmount, *plHook, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff number for ACF services - this is by definition '005' |
[out] BSTR | *pbstrCode | The service code of the ACF service |
[out] BSTR | *pbstrReferenceCode | The reference code. Since there are no official reference codes for tariff 005, a code here is always interpreted as ICD10 code (supplied via AddService). |
[out] double | *pdQuantity | The floating point quantity. |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] DATE | *pdDate | The date of the service's prescription |
[out] SideType | *peSide | The body side dependency of the service |
[out] BSTR | *pbstrName | The name of the service as defined by the tariff owner OAAT |
[out] double | *pdTP | The tax points (TP) of the ACF service. |
[out] double | *pdTPValue | The tax point value (TPV) of the ACF service as defined by the cantons. |
[out] double | *pdExternalFactor | The external factor is used and defined by OAAT as modulation factor within its cost neutrality project. |
[out] double | *pdAmount | The amount in CHF of the service supplied in 2-digit precision. Note that the equation: Amount = (ExternalFactor * Quantity * TP * TPValue) holds true |
[out] long | *plHook | The external hook, that was provided in the AddService call. The lHook ID primarily serves to identify this service when the services are read back. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidate005
  • GetNextService

IValidate005::GetNextService method |  |  | space
Gets the next ACF service from the list of services. VARIANT_FALSE is returned if the end of the service list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate005/GetNextService
[JSON input data] | pIValidate005: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrCode: pbstrReferenceCode: pdQuantity: plSessionNumber: pdDate: peSide: pbstrName: pdTP: pdTPValue: pdExternalFactor: pdAmount: plHook: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, longValue, "stringISODateValue", longValue, "utf8StringValue", doubleValue, doubleValue, doubleValue, doubleValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextService( | BSTR BSTR BSTR double long DATE SideType BSTR double double double double long VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrReferenceCode, *pdQuantity, *plSessionNumber, *pdDate, *peSide, *pbstrName, *pdTP, *pdTPValue, *pdExternalFactor, *pdAmount, *plHook, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff number for ACF services - this is by definition '005' |
[out] BSTR | *pbstrCode | The service code of the ACF service |
[out] BSTR | *pbstrReferenceCode | The reference code. Since there are no official reference codes for tariff 005, a code here is always interpreted as ICD10 code (supplied via AddService). |
[out] double | *pdQuantity | The floating point quantity. |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] DATE | *pdDate | The date of the service's prescription |
[out] SideType | *peSide | The body side dependency of the service |
[out] BSTR | *pbstrName | The name of the service as defined by the tariff owner OAAT |
[out] double | *pdTP | The tax points (TP) of the ACF service. |
[out] double | *pdTPValue | The tax point value (TPV) of the ACF service as defined by the cantons. |
[out] double | *pdExternalFactor | The external factor is used and defined by OAAT as modulation factor within its cost neutrality project. |
[out] double | *pdAmount | The amount in CHF of the service supplied in 2-digit precision. Note that the equation: Amount = (ExternalFactor * Quantity * TP * TPValue) holds true |
[out] long | *plHook | The external hook, that was provided in the AddService call. The lHook ID primarily serves to identify this service when the services are read back. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidate005
  • GetServices

IValidate005::GetServices method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all ACF services in one call without the necessity to call the iterator pair IValidate005::GetFirstService / IValidate005::GetNextService. The service records are returned as JSON array however large that array size might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate005/GetServices
[JSON input data] | pIValidate005: | longValue, //interface address
[JSON result array] | { pbstrTariffType: pbstrCode: pbstrReferenceCode: pdQuantity: plSessionNumber: pdDate: peSide: pbstrName: pdTP: pdTPValue: pdExternalFactor: pdAmount: plHook: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, longValue, "stringISODateValue", longValue, "utf8StringValue", doubleValue, doubleValue, doubleValue, doubleValue, longValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff number for ACF services - this is by definition '005' |
[out] BSTR | *pbstrCode | The service code of the ACF service |
[out] BSTR | *pbstrReferenceCode | The reference code. Since there are no official reference codes for tariff 005, a code here is always interpreted as ICD10 code (supplied via AddService). |
[out] double | *pdQuantity | The floating point quantity. |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] DATE | *pdDate | The date of the service's prescription |
[out] SideType | *peSide | The body side dependency of the service |
[out] BSTR | *pbstrName | The name of the service as defined by the tariff owner OAAT |
[out] double | *pdTP | The tax points (TP) of the ACF service. |
[out] double | *pdTPValue | The tax point value (TPV) of the ACF service as defined by the cantons. |
[out] double | *pdExternalFactor | The external factor is used and defined by OAAT as modulation factor within its cost neutrality project. |
[out] double | *pdAmount | The amount in CHF of the service supplied in 2-digit precision. Note that the equation: Amount = (ExternalFactor * Quantity * TP * TPValue) holds true |
[out] long | *plHook | The external hook, that was provided in the AddService call. The lHook ID primarily serves to identify this service when the services are read back. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidate005
  • Initialize

IValidate005::Initialize method |  |  | space
Initializes the validation and clears all previously added TMA service records |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidate005/Initialize
[JSON input data] | pIValidate005: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IValidate005
  • Amount

IValidate005::Amount property | space
The amount of the service in CHF calculated by the equation Amount = (ExternalFactor * Quantity * TP * TPValue).
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetAmount?param
[param] pIValidate005= longValue
[JSON result data] pdAmount: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Amount( double *pdAmount );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdAmount | The amount of the service in CHF
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetAmount(void);
space


  • IValidate005
  • Code

IValidate005::Code property | space
The ACF code of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetCode?param
[param] pIValidate005= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The ACF code of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • IValidate005
  • Date

IValidate005::Date property | space
The date of the service provision
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetDate?param
[param] pIValidate005= longValue
[JSON result data] pdDate: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Date( double *pdDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdDate | The defined date of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetDate(void);
space


  • IValidate005
  • DestructValidate005

IValidate005::DestructValidate005 property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidate005 interface instance. The counterpart property to generate an ISearch005 interface instance is IAcfValidator::GetCreateValidate005. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IValidate005/PutDestructValidate005
[JSON input data] | pIValidate005: eDestructValidate005: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IValidate005
  • ExternalFactor

IValidate005::ExternalFactor property | space
The external factor of the ACF service as defined by OAAT
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetExternalFactor?param
[param] pIValidate005= longValue
[JSON result data] pdExternalFactor: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor( double *pdExternalFactor );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdExternalFactor | The external factor of the current ACF service as defined by OAAT
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor(void);
space


  • IValidate005
  • Hook

IValidate005::Hook property | space
The hook of the selected service (external ID)
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetHook?param
[param] pIValidate005= longValue
[JSON result data] plHook: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Hook( long *plHook );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plHook | The hook of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetHook(void);
space


  • IValidate005
  • IgnoreValidate

IValidate005::IgnoreValidate property | space
Flag indicating whether the validation was ignored or not
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetIgnoreValidate?param
[param] pIValidate005= longValue
[JSON result data] peIgnoreValidate: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | IgnoreValidate( YesNoType *peIgnoreValidate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peIgnoreValidate | Boolean that defines if the current service has a 'ignore validate' status (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetIgnoreValidate(void);
space


  • IValidate005
  • Name

IValidate005::Name property | space
The name of the selected ACF service
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetName?param
[param] pIValidate005= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current ACF service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • IValidate005
  • Quantity

IValidate005::Quantity property | space
The quantity of the ACF service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetQuantity?param
[param] pIValidate005= longValue
[JSON result data] pdQuantity: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Quantity( double *pdQuantity );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdQuantity | The quantity of the current ACF service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetQuantity(void);
space


  • IValidate005
  • ReferenceCode

IValidate005::ReferenceCode property | space
The reference code.

Since there are no official reference codes for tariff 005, a code here is always interpreted as ICD10 code (supplied via AddService).

space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetReferenceCode?param
[param] pIValidate005= longValue
[JSON result data] pbstrReferenceCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ReferenceCode( BSTR *pbstrReferenceCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrReferenceCode | The reference code of the current service, which is by design an ICD10 code
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetReferenceCode(void);
space


  • IValidate005
  • SessionNumber

IValidate005::SessionNumber property | space
The session number or patient contact ID.

Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data).

space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetSessionNumber?param
[param] pIValidate005= longValue
[JSON result data] plSessionNumber: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SessionNumber( long *plSessionNumber );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plSessionNumber | The currently set session number
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetSessionNumber(void);
space


  • IValidate005
  • SideType

IValidate005::SideType property | space
The side dependency of the ACF service
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetSideType?param
[param] pIValidate005= longValue
[JSON result data] peSideType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SideType( SideType *peSideType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] SideType | *peSideType | side dependency code
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • SideType *GetSideType(void);
space


  • IValidate005
  • TariffType

IValidate005::TariffType property | space
The tariff type the selected ACF service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetTariffType?param
[param] pIValidate005= longValue
[JSON result data] pbstrTariffType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TariffType( BSTR *pbstrTariffType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTariffType | The tariff type the selected ACF service record - always return '005'
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTariffType(void);
space


  • IValidate005
  • TP

IValidate005::TP property | space
The valid tax points (TP) of the ACF service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetTP?param
[param] pIValidate005= longValue
[JSON result data] pdTP: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP( double *pdTP );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP | The tax points (TP) of the current ACF service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP(void);
space


  • IValidate005
  • TPValue

IValidate005::TPValue property | space
The tax point value of the ACF service as defined by the cantons
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidate005/GetTPValue?param
[param] pIValidate005= longValue
[JSON result data] pdTPValue: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TPValue( double *pdTPValue );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTPValue | The tax point value (TPV) of the current ACF service as defined by the cantons
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTPValue(void);
space


  • IValidateTMA

IValidateTMA interface | V1.00/ 3 Aug 2025
The IValidateTMA interface allows for the input and validation of supplied service data. The validation checks whether the data conforms to the rule set of the selected service. There will be a rejection of a supplied service if it is in conflict with another service or with some inherent rules.

Furthermore, a specific subset of TMA-services, one having the same session number and for which an ICD10 and capitulum code as well as a patient age and sex is connected, is targeted for the grouping process. Such a groupeing result in a named ACF service code or the error code 'ERR_NO.ambP' meaning that a grouping is not possible.

All data and the calculated amount of a service can be retrieved can be retrieved with the interface"s properties. Finally, after all service records have been added the finalize methods starts all finale rule checks and returns the number of Ambulatory Case Flatrates and the summed up amount over all services.

space
space
Methods | 12 methods
AddACFBase | Adds a new ACFBase data container to the list of ACFBase objects
AddService | Adds a new TMA service to the list of services which will be validated against all previously added services of the same session
Finalize | Validate all TMA services by running the "late binding" rules and than run a grouper process for all available ACFBase elements
GetAbortInfo | Fetches the abort/error information if there is any stored
GetACFBases | Method for collecting all ACFBase elements in one call without the necessity to call the iterator pair IValidateTMA::GetFirstACFBase / IValidateTMA::GetNextACFBase
GetFirstACFBase | Retrieves the first ACFBase element from the list of ACFBase elements
GetFirstService | Gets the first TMA service from the list of services
GetNextACFBase | Gets the next ACFBase element from the list of ACFBase elements
GetNextService | Gets the next TMA service from the list of services
GetServices | Method for collecting all TMA services in one call without the necessity to call the iterator pair IValidateTMA::GetFirstService / IValidateTMA::GetNextService
Initialize | Initializes the validation and clears all previously added TMA service records
RunGrouper | Starts a grouping attempt for the specified sessionNumber or for all ACFBase elements if sessionNumber = -1
space
Properties | 17 properties
[get] Amount | The amount of the service in CHF calculated by the equation Amount = (ExternalFactor * Quantity * TP * TPValue)
[get] Code | The TMA code of the selected service record
[get] Date | The date of the service provision
[put] DestructValidateTMA | Destructs/invalidates this IValidateTMA interface instance
[get] ExternalFactor | The external factor of the TMA service
[get] Hook | The hook of the selected service (external ID)
[get] IgnoreValidate | Flag indicating whether the validation was ignored or not
[get] Name | The name of the selected TMA service
[get] Quantity | The quantity of the TMA service record
[get] ReferenceCode | The supplied reference code
[get] ServiceProperties | This value defines all semantic capabilities of a service
[get] SessionNumber | The session number or patient contact ID
[get] SideType | The side dependency of the TMA service
[get] TariffType | The tariff type the selected TMA service record belongs to
[get] TMAType | The characterization/type affiliation of the TMA service-the possible value range is predefined in TMAType.
[get] TP | The valid tax points (TP) of the TMA service record
[get] TPValue | The tax point value of the TMA service
space


  • IValidateTMA
  • AddACFBase

IValidateTMA::AddACFBase method | space
Adds a new ACFBase data container to the list of ACFBase objects. Each such ACFBase objects couples via the session number base data like the ICD code and some patient data (sex and age) with TMA services. Each such ACFBase object is a target for a grouping process and the resulting ACF code is stored in the ACFBase object, subject to the inspection with the iterator pair IValidateTMA::GetFirstACFBase / IValidateTMA::GetNextACFBase.
space
Restful webservice calling syntax
[POST] | /baseURL/ IValidateTMA/AddACFBase
[JSON input data] pIValidateTMA:
lSessionNumber:
bstrICDCode:
ePatientSex:
dPatientBirthdate:
eLaw: 		longValue, //interface address
longValue,
"utf8StringValue",
longValue,
variantDateValue | "stringISODateValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT AddACFBase( long
BSTR
SexType
DATE
LawType
VARIANT_BOOL 		lSessionNumber,
bstrICDCode,
ePatientSex,
dPatientBirthdate,
eLaw,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] long lSessionNumber The session number or patient contact ID.

Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data).

[in] BSTR bstrICDCode The ICD10 code that must be used in the grouping process.

Please note that an empty ICD10 counts as legal input (it nevertheless should be avoided!), whereas an ICD10 code not available in the grouper's ICD space counts as error.

[in] SexType | ePatientSex | The patient's medical sex, either 'enMale' or 'enFemale'
[in] DATE | dPatientBirthdate | The patient's birthdate, that is primarely used for calculating the patient's age.
[in] LawType eLaw The law under which the case is running.

Please note, that currently there is no law dependency, but this might change in future. So whatever you currently input is not used at the moment.

[out,retval] VARIANT_BOOL *pbStatus The principal validation status
  • =0 is returned for success
  • >0 indicates that a validation rule was not fulfilled - the service is not added. Use the GetAbortInfo to get an error description string.
  • <0 indicates a severe principal COM automation error - the service is not added. Use the GetAbortInfo to get an error description string.
space


  • IValidateTMA
  • AddService

IValidateTMA::AddService method | space
Adds a new TMA service to the list of services which will be validated against all previously added services of the same session. If the code supplied passes all validations a VARIANT_TRUE value is returned. If the code was not accepted VARIANT_FALSE is returned and the variable plStatus contains the error code.

Please note that the drug "7680664950014 = SPINRAZA Inj Sol 12 mg/5ml" is included in the LKAAT tarif and can be added by simply use the GTIN as bstrCode.

Furthermore, foreign services (services not included in the LKAAT) can be added as pro memoria services by supplying the name and the extended code tariffNumber@tariffCode (e.g. bstrCode= "402@7680444480250" and bstrName="DORMICUM 5 mg/ml i.v., i.m, rectal"). Internally, the tariff number is stripped away and stored under the reference code. All foreign services are automatically defined as not grouper relevant, that is dExternalFactor=0 is set/returned.

space
Restful webservice calling syntax
[POST] | /baseURL/ IValidateTMA/AddService
[JSON input data] pIValidateTMA:
bstrCode:
bstrReferenceCode:
dQuantity:
lSessionNumber:
dDate:
eSide:
bstrName:
eIgnoreValidate:
lHook: 		longValue, //interface address
"utf8StringValue",
"utf8StringValue",
doubleValue,
longValue,
variantDateValue | "stringISODateValue",
longValue,
"utf8StringValue",
longValue,
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT AddService( BSTR
BSTR
double
long
DATE
SideType
BSTR
YesNoType
long
VARIANT_BOOL 		bstrCode,
bstrReferenceCode,
dQuantity,
lSessionNumber,
dDate,
eSide,
bstrName,
eIgnoreValidate,
lHook,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrCode Code of the service.

This code can be a drug's GTIN - cf below at bstrName.

[in] BSTR bstrReferenceCode The reference code of the service. The reference code must be set if the enServicePropertyIsNeedsRefCode bit of that service is defined.
If a reference code is needed than that parent service must be supplied before this one.
[in] double | dQuantity | Quantity of the service
[in] long lSessionNumber The session number or patient contact ID.

Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the service and link it to the corresponding ICD and capitulum code.

[in] DATE | dDate | Date of the service to ensure that the validity date range is obeyed
[in] SideType | eSide | The side for which the service is applied or enSideNone if there is noSideDependeny
[in] BSTR bstrName The service name.

Under normal circumstances you will leave the name variable empty. However if you input a drug by setting the bstrCode=GTIN, than you have to supply the drug's name here since there is no database lookup available inside the module.

[in] YesNoType eIgnoreValidate Flag indicating whether the validation should be ignored or not.
To turn off the validation might be useful in the situation when a service should be added even if the validation failed due to a special agreement with the insurance or patient.
[in] long | lHook | The external hook, that was provided in the AddService call. The lHook ID primarily serves to identify this service when the services are read back.
[out,retval] VARIANT_BOOL *pbStatus The principal validation status
  • =0 is returned for success
  • >0 indicates that a validation rule was not fulfilled - the service is not added. Use the GetAbortInfo to get an error description string.
  • <0 indicates a severe principal COM automation error - the service is not added. Use the GetAbortInfo to get an error description string.
space


  • IValidateTMA
  • Finalize

IValidateTMA::Finalize method |  |  | space
Validate all TMA services by running the "late binding" rules and than run a grouper process for all available ACFBase elements. The result of these grouping processes is return by the Finalize methods. Please note, that a plethora of checks are undertaken (e.g. no ACFBase elements, no TMA services for a ACFBase element, orphant TMA services, etc), whose result might be returned as error. There is one logical 'error' that is not returned via an error code: the non-grouping status, also known as 'no.ambP'. Therefore check both returned variables for consistency and/or consult the iterator pair IValidateTMA::GetFirstACFBase / IValidateTMA::GetNextACFBasefor in-depth insight. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/Finalize
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result data] | plNumACF: pbstrGroupingStatusList: pbStatus: | longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Finalize( | long BSTR VARIANT_BOOL | *plNumACF, *pbstrGroupingStatusList, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plNumACF | The number of ACFBase elements having a distinct sessionNumber |
[out] BSTR | *pbstrGroupingStatusList | A hash separated list of grouping states formatted as sessionNumber(ACFCode)# (e.g. 35(C08.26C) or 37(ERR_NO.amP) ). Note that the latter example shows the non-grouping result! |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidateTMA
  • GetAbortInfo

IValidateTMA::GetAbortInfo method |  |  | space
Fetches the abort/error information if there is any stored. If any method generates an error/error string than the error situation is signaled by the VARIANT_BOOL status of that method. GetAbortInfo can then be used to retrieve the error code und error string. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/GetAbortInfo
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result data] | pbstrAbortText: plAbortCode: pbStatus: | "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR long VARIANT_BOOL | *pbstrAbortText, *plAbortCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbortText | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out] long | *plAbortCode | The abort information string that corresponds with the abort/error code. The abort string is empty if there is no error condition. Possibly S_FALSE was set by an iterator to signal end_of_data, which is seen as a "non-error". |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IValidateTMA
  • GetACFBases

IValidateTMA::GetACFBases method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all ACFBase elements in one call without the necessity to call the iterator pair IValidateTMA::GetFirstACFBase / IValidateTMA::GetNextACFBase. The ACFBase records are returned as JSON array however large that array size might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/GetACFBases
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result array] | { plSessionNumber: pbstrICDCode: pbstrChapterCode: pePatientSex: pdPatientBirthdate: peLaw: pdFirstDate: plGroupingTries: peGroupingSuccess: pbstrACFCode: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", longValue, "stringISODateValue", longValue, "stringISODateValue", longValue, longValue, "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] BSTR | *pbstrICDCode | The ICD10 code that is used in the grouping process. |
[out] BSTR | *pbstrChapterCode | The capitulum code e.g. 'Cap08', extracted from the chapter affiliation of the ICD10 code |
[out] SexType | *pePatientSex | The patient's medical sex, either 'enMale' or 'enFemale' |
[out] DATE | *pdPatientBirthdate | The patient's birthdate, that is primarely used for calculating the patient's age. |
[out] LawType | *peLaw | The law under which the case is running. Please note, that currently there is no law dependency, but this might change in future. So whatever you currently input is not used at the moment. |
[out] DATE | *pdFirstDate | The first service date that references to this session number |
[out] long | *plGroupingTries | Initially set to 0, the lGroupingTries is incremented by 1 each time of grouping this ACFBase element. Note that the variable is incremented if the grouping is successful or not. |
[out] YesNoType | *peGroupingSuccess | A YesNoType that is enYes for a successful grouping with a resulting ACF code, otherwise enNo results. |
[out] BSTR | *pbstrACFCode | If eGroupingSuccess=enYes than bstrACFCode holds the resulting ACF code, empty otherwise. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidateTMA
  • GetFirstACFBase

IValidateTMA::GetFirstACFBase method |  |  | space
Retrieves the first ACFBase element from the list of ACFBase elements. VARIANT_FALSE is returned if the end of the service list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/GetFirstACFBase
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result data] | plSessionNumber: pbstrICDCode: pbstrChapterCode: pePatientSex: pdPatientBirthdate: peLaw: pdFirstDate: plGroupingTries: peGroupingSuccess: pbstrACFCode: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", longValue, "stringISODateValue", longValue, "stringISODateValue", longValue, longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstACFBase( | long BSTR BSTR SexType DATE LawType DATE long YesNoType BSTR VARIANT_BOOL | *plSessionNumber, *pbstrICDCode, *pbstrChapterCode, *pePatientSex, *pdPatientBirthdate, *peLaw, *pdFirstDate, *plGroupingTries, *peGroupingSuccess, *pbstrACFCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] BSTR | *pbstrICDCode | The ICD10 code that is used in the grouping process. |
[out] BSTR | *pbstrChapterCode | The capitulum code e.g. 'Cap08', extracted from the chapter affiliation of the ICD10 code |
[out] SexType | *pePatientSex | The patient's medical sex, either 'enMale' or 'enFemale' |
[out] DATE | *pdPatientBirthdate | The patient's birthdate, that is primarely used for calculating the patient's age. |
[out] LawType | *peLaw | The law under which the case is running. Please note, that currently there is no law dependency, but this might change in future. So whatever you currently input is not used at the moment. |
[out] DATE | *pdFirstDate | The first service date that references to this session number |
[out] long | *plGroupingTries | Initially set to 0, the lGroupingTries is incremented by 1 each time of grouping this ACFBase element. Note that the variable is incremented if the grouping is successful or not. |
[out] YesNoType | *peGroupingSuccess | A YesNoType that is enYes for a successful grouping with a resulting ACF code, otherwise enNo results. |
[out] BSTR | *pbstrACFCode | If eGroupingSuccess=enYes than bstrACFCode holds the resulting ACF code, empty otherwise. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidateTMA
  • GetFirstService

IValidateTMA::GetFirstService method |  |  | space
Gets the first TMA service from the list of services. VARIANT_FALSE is returned if the end of the service list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/GetFirstService
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrCode: pbstrReferenceCode: pdQuantity: plSessionNumber: pdDate: peSide: pbstrName: pdTP: pdTPValue: pdExternalFactor: pdAmount: plHook: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, longValue, "stringISODateValue", longValue, "utf8StringValue", doubleValue, doubleValue, doubleValue, doubleValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstService( | BSTR BSTR BSTR double long DATE SideType BSTR double double double double long VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrReferenceCode, *pdQuantity, *plSessionNumber, *pdDate, *peSide, *pbstrName, *pdTP, *pdTPValue, *pdExternalFactor, *pdAmount, *plHook, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff number for LKAAT services - this is by definition 'TMA' |
[out] BSTR | *pbstrCode | The service code of the TMA service |
[out] BSTR | *pbstrReferenceCode | The reference code |
[out] double | *pdQuantity | The floating point quantity. |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] DATE | *pdDate | The date of the service's provision |
[out] SideType | *peSide | The body side dependency of the service |
[out] BSTR | *pbstrName | The name of the TMA service as defined by the tariff owner OAAT |
[out] double | *pdTP | The tax points (TP) of the TMA service - this is by definition 0.00 |
[out] double | *pdTPValue | The tax point value (TPV) of the TMA service - this is by definition 1.00 |
[out] double | *pdExternalFactor | The external factor of the service. This external factor is initially predefined as 1.00. However, if the corresponding service is not used/neglegted in the grouping process, it is reset to 0.0 to reflect its non-usability. |
[out] double | *pdAmount | The amount of the TMA service - this is by definition 0.0 as at least dTP is 0.00 as well. |
[out] long | *plHook | The external hook, that was provided in the AddService call. The lHook ID primarily serves to identify this service when the services are read back. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidateTMA
  • GetNextACFBase

IValidateTMA::GetNextACFBase method |  |  | space
Gets the next ACFBase element from the list of ACFBase elements. VARIANT_FALSE is returned if the end of the service list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/GetNextACFBase
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result data] | plSessionNumber: pbstrICDCode: pbstrChapterCode: pePatientSex: pdPatientBirthdate: peLaw: pdFirstDate: plGroupingTries: peGroupingSuccess: pbstrACFCode: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", longValue, "stringISODateValue", longValue, "stringISODateValue", longValue, longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextACFBase( | long BSTR BSTR SexType DATE LawType DATE long YesNoType BSTR VARIANT_BOOL | *plSessionNumber, *pbstrICDCode, *pbstrChapterCode, *pePatientSex, *pdPatientBirthdate, *peLaw, *pdFirstDate, *plGroupingTries, *peGroupingSuccess, *pbstrACFCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] BSTR | *pbstrICDCode | The ICD10 code that is used in the grouping process. |
[out] BSTR | *pbstrChapterCode | The capitulum code e.g. 'Cap08', extracted from the chapter affiliation of the ICD10 code |
[out] SexType | *pePatientSex | The patient's medical sex, either 'enMale' or 'enFemale' |
[out] DATE | *pdPatientBirthdate | The patient's birthdate, that is primarely used for calculating the patient's age. |
[out] LawType | *peLaw | The law under which the case is running. Please note, that currently there is no law dependency, but this might change in future. So whatever you currently input is not used at the moment. |
[out] DATE | *pdFirstDate | The first service date that references to this session number |
[out] long | *plGroupingTries | Initially set to 0, the lGroupingTries is incremented by 1 each time of grouping this ACFBase element. Note that the variable is incremented if the grouping is successful or not. |
[out] YesNoType | *peGroupingSuccess | A YesNoType that is enYes for a successful grouping with a resulting ACF code, otherwise enNo results. |
[out] BSTR | *pbstrACFCode | If eGroupingSuccess=enYes than bstrACFCode holds the resulting ACF code, empty otherwise. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidateTMA
  • GetNextService

IValidateTMA::GetNextService method |  |  | space
Gets the next TMA service from the list of services. VARIANT_FALSE is returned if the end of the service list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/GetNextService
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result data] | pbstrTariffType: pbstrCode: pbstrReferenceCode: pdQuantity: plSessionNumber: pdDate: peSide: pbstrName: pdTP: pdTPValue: pdExternalFactor: pdAmount: plHook: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, longValue, "stringISODateValue", longValue, "utf8StringValue", doubleValue, doubleValue, doubleValue, doubleValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextService( | BSTR BSTR BSTR double long DATE SideType BSTR double double double double long VARIANT_BOOL | *pbstrTariffType, *pbstrCode, *pbstrReferenceCode, *pdQuantity, *plSessionNumber, *pdDate, *peSide, *pbstrName, *pdTP, *pdTPValue, *pdExternalFactor, *pdAmount, *plHook, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff number for LKAAT services - this is by definition 'TMA' |
[out] BSTR | *pbstrCode | The service code of the TMA service |
[out] BSTR | *pbstrReferenceCode | The reference code |
[out] double | *pdQuantity | The floating point quantity. |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] DATE | *pdDate | The date of the service's provision |
[out] SideType | *peSide | The body side dependency of the service |
[out] BSTR | *pbstrName | The name of the TMA service as defined by the tariff owner OAAT |
[out] double | *pdTP | The tax points (TP) of the TMA service - this is by definition 0.00 |
[out] double | *pdTPValue | The tax point value (TPV) of the TMA service - this is by definition 1.00 |
[out] double | *pdExternalFactor | The external factor of the service. This external factor is initially predefined as 1.00. However, if the corresponding service is not used/neglegted in the grouping process, it is reset to 0.0 to reflect its non-usability. |
[out] double | *pdAmount | The amount of the TMA service - this is by definition 0.0 as at least dTP is 0.00 as well. |
[out] long | *plHook | The external hook, that was provided in the AddService call. The lHook ID primarily serves to identify this service when the services are read back. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidateTMA
  • GetServices

IValidateTMA::GetServices method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all TMA services in one call without the necessity to call the iterator pair IValidateTMA::GetFirstService / IValidateTMA::GetNextService. The service records are returned as JSON array however large that array size might be. So this might be a memory and performance bottleneck. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/GetServices
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result array] | { pbstrTariffType: pbstrCode: pbstrReferenceCode: pdQuantity: plSessionNumber: pdDate: peSide: pbstrName: pdTP: pdTPValue: pdExternalFactor: pdAmount: plHook: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", doubleValue, longValue, "stringISODateValue", longValue, "utf8StringValue", doubleValue, doubleValue, doubleValue, doubleValue, longValue, booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrTariffType | The official tariff number for LKAAT services - this is by definition 'TMA' |
[out] BSTR | *pbstrCode | The service code of the TMA service |
[out] BSTR | *pbstrReferenceCode | The reference code |
[out] double | *pdQuantity | The floating point quantity. |
[out] long | *plSessionNumber | The session number or patient contact ID. Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data). |
[out] DATE | *pdDate | The date of the service's provision |
[out] SideType | *peSide | The body side dependency of the service |
[out] BSTR | *pbstrName | The name of the TMA service as defined by the tariff owner OAAT |
[out] double | *pdTP | The tax points (TP) of the TMA service - this is by definition 0.00 |
[out] double | *pdTPValue | The tax point value (TPV) of the TMA service - this is by definition 1.00 |
[out] double | *pdExternalFactor | The external factor of the service. This external factor is initially predefined as 1.00. However, if the corresponding service is not used/neglegted in the grouping process, it is reset to 0.0 to reflect its non-usability. |
[out] double | *pdAmount | The amount of the TMA service - this is by definition 0.0 as at least dTP is 0.00 as well. |
[out] long | *plHook | The external hook, that was provided in the AddService call. The lHook ID primarily serves to identify this service when the services are read back. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IValidateTMA
  • Initialize

IValidateTMA::Initialize method |  |  | space
Initializes the validation and clears all previously added TMA service records |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IValidateTMA/Initialize
[JSON input data] | pIValidateTMA: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value. |
space |


  • IValidateTMA
  • RunGrouper

IValidateTMA::RunGrouper method | space
Starts a grouping attempt for the specified sessionNumber or for all ACFBase elements if sessionNumber = -1.

Please note that this method performs various error checks before the actual grouping. These include ACFBase(sessionNumber) does not exist, no TMA services for given sessionNumber.

If a complete grouping is performed (sessionNumber = -1), then orphaned TMA services (services without ACFBase coupling) are also searched for.

space
Restful webservice calling syntax
[POST] | /baseURL/ IValidateTMA/RunGrouper
[JSON input data] pIValidateTMA:
lSessionNumber: 		longValue, //interface address
longValue
[JSON result data] pbstrGroupingStatusList:
pbStatus: 		"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT RunGrouper( long
BSTR
VARIANT_BOOL 		lSessionNumber,
*pbstrGroupingStatusList,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] long lSessionNumber The ACFBase session number whose grouping is requested.
If session number is defined as -1, than the grouping takes place over all defined ACFBase elements.
[out] BSTR | *pbstrGroupingStatusList | A hash separated list of grouping states formatted as sessionNumber(ACFCode)# (e.g. 35(C08.26C) or 37(ERR_NO.amP) ). Note that the latter example shows the non-grouping result!
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string and value.
space


  • IValidateTMA
  • Amount

IValidateTMA::Amount property | space
The amount of the service in CHF calculated by the equation Amount = (ExternalFactor * Quantity * TP * TPValue).
This variable is always 0.00 in the TMA tariff, as the TP is per definition 0.00
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetAmount?param
[param] pIValidateTMA= longValue
[JSON result data] pdAmount: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Amount( double *pdAmount );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdAmount | The amount
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetAmount(void);
space


  • IValidateTMA
  • Code

IValidateTMA::Code property | space
The TMA code of the selected service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetCode?param
[param] pIValidateTMA= longValue
[JSON result data] pbstrCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Code( BSTR *pbstrCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrCode | The TMA code of the selected service record
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetCode(void);
space


  • IValidateTMA
  • Date

IValidateTMA::Date property | space
The date of the service provision
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetDate?param
[param] pIValidateTMA= longValue
[JSON result data] pdDate: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Date( double *pdDate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdDate | The defined date of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetDate(void);
space


  • IValidateTMA
  • DestructValidateTMA

IValidateTMA::DestructValidateTMA property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IValidateTMA interface instance. The counterpart property to generate an ISearch005 interface instance is IAcfValidator::GetCreateValidateTMA. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IValidateTMA/PutDestructValidateTMA
[JSON input data] | pIValidateTMA: eDestructValidateTMA: | longValue, //interface address longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IValidateTMA
  • ExternalFactor

IValidateTMA::ExternalFactor property | space
The external factor of the TMA service
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetExternalFactor?param
[param] pIValidateTMA= longValue
[JSON result data] pdExternalFactor: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ExternalFactor( double *pdExternalFactor );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double *pdExternalFactor The external factor of the current TMA service.
By definition this is always 1.00 unless the given service was not used in the grouping. In such a case, the external factor is set to 0.00 to indicate that it is not used during the grouping process.
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetExternalFactor(void);
space


  • IValidateTMA
  • Hook

IValidateTMA::Hook property | space
The hook of the selected service (external ID)
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetHook?param
[param] pIValidateTMA= longValue
[JSON result data] plHook: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Hook( long *plHook );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plHook | The hook of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetHook(void);
space


  • IValidateTMA
  • IgnoreValidate

IValidateTMA::IgnoreValidate property | space
Flag indicating whether the validation was ignored or not
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetIgnoreValidate?param
[param] pIValidateTMA= longValue
[JSON result data] peIgnoreValidate: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | IgnoreValidate( YesNoType *peIgnoreValidate );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] YesNoType | *peIgnoreValidate | Boolean that defines if the current service has a 'ignore validate' status (enYes) or not (enNo)
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • YesNoType *GetIgnoreValidate(void);
space


  • IValidateTMA
  • Name

IValidateTMA::Name property | space
The name of the selected TMA service
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetName?param
[param] pIValidateTMA= longValue
[JSON result data] pbstrName: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Name( BSTR *pbstrName );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrName | The name of the current TMA service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetName(void);
space


  • IValidateTMA
  • Quantity

IValidateTMA::Quantity property | space
The quantity of the TMA service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetQuantity?param
[param] pIValidateTMA= longValue
[JSON result data] pdQuantity: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Quantity( double *pdQuantity );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdQuantity | The quantity of the current TMA service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetQuantity(void);
space


  • IValidateTMA
  • ReferenceCode

IValidateTMA::ReferenceCode property | space
The supplied reference code.

When set this means that there is a Master-Slave relation between reference code (master) and code (slave). Furthermore a master service must always be inputted prior to the slave service.

space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetReferenceCode?param
[param] pIValidateTMA= longValue
[JSON result data] pbstrReferenceCode: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ReferenceCode( BSTR *pbstrReferenceCode );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrReferenceCode | Reference code
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetReferenceCode(void);
space


  • IValidateTMA
  • ServiceProperties

IValidateTMA::ServiceProperties property | space
This value defines all semantic capabilities of a service.
The value is a 32-bit integer composed from ORed values of the ServicePropertyType enumeration list.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetServiceProperties?param
[param] pIValidateTMA= longValue
[JSON result data] plServiceProperties: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ServiceProperties( long *plServiceProperties );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plServiceProperties | The ORed service properties of the current service
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetServiceProperties(void);
space


  • IValidateTMA
  • SessionNumber

IValidateTMA::SessionNumber property | space
The session number or patient contact ID.

Please note that the 'SessionNumber" plays a central role in the ACF/LKAAT tariffs, in that this ID serves as a grouping and connection object to combine services (even across days). Furthermore, the same ID is also used in the TMA tariff to bundle the services and link it to the corresponding global data (ICD and patient data).

space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetSessionNumber?param
[param] pIValidateTMA= longValue
[JSON result data] plSessionNumber: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SessionNumber( long *plSessionNumber );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] long | *plSessionNumber | The currently set session number
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • long *GetSessionNumber(void);
space


  • IValidateTMA
  • SideType

IValidateTMA::SideType property | space
The side dependency of the TMA service
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetSideType?param
[param] pIValidateTMA= longValue
[JSON result data] peSideType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | SideType( SideType *peSideType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] SideType | *peSideType | side dependency code
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • SideType *GetSideType(void);
space


  • IValidateTMA
  • TariffType

IValidateTMA::TariffType property | space
The tariff type the selected TMA service record belongs to
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetTariffType?param
[param] pIValidateTMA= longValue
[JSON result data] pbstrTariffType: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TariffType( BSTR *pbstrTariffType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrTariffType | The tariff type the selected TMA service record - always return 'TMA'
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetTariffType(void);
space


  • IValidateTMA
  • TMAType

IValidateTMA::TMAType property | space
The characterization/type affiliation of the TMA service-the possible value range is predefined in TMAType.
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetTMAType?param
[param] pIValidateTMA= longValue
[JSON result data] peTMAType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TMAType( TMAType *peTMAType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] TMAType | *peTMAType | The TMAType value
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • TMAType *GetTMAType(void);
space


  • IValidateTMA
  • TP

IValidateTMA::TP property | space
The valid tax points (TP) of the TMA service record
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetTP?param
[param] pIValidateTMA= longValue
[JSON result data] pdTP: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TP( double *pdTP );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTP | The tax points (TP) of the current TMA service - per definition this is always 0.00
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTP(void);
space


  • IValidateTMA
  • TPValue

IValidateTMA::TPValue property | space
The tax point value of the TMA service
space
Restful webservice calling syntax
[GET] | /baseURL/ IValidateTMA/GetTPValue?param
[param] pIValidateTMA= longValue
[JSON result data] pdTPValue: doubleValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | TPValue( double *pdTPValue );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] double | *pdTPValue | The tax point value (TPV) of the current TMA service - per definition this is always 1.00
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • double *GetTPValue(void);
space


  • Type definitions

Builtin, composite & enumeration types |  | V1.00/ 3 Aug 2025
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
space
Data types |  | 21 types
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[enumeration] CantonType | Enumerates the defined Swiss cantons or neighboring countries. |
[builtin] DATE | A value denoting a date and time was specified |
[builtin] double | An 8-byte IEEE real value |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning |
[builtin] ISearch005 | ISearch005 interface |
[builtin] ISearchTMA | ISearchTMA interface |
[builtin] IValidate005 | IValidate005 interface |
[builtin] IValidateTMA | IValidateTMA interface |
[enumeration] LanguageType | Enumerates all supported languages |
[enumeration] LawType | Enumerates the supported legal law set. |
[builtin] long | A 4-byte integer value |
[enumeration] PlaceType | Enumerates the defined places where the main provider is located |
[enumeration] RoleType | Enumerates the defined role categories that the main provider is best categorized |
[enumeration] ServicePropertyType | Defines properties a service possibly can possess in terms of an orthogonal bit list. |
[enumeration] SexType | Enumerates the defined gender categories |
[enumeration] SideType | Enumerates the defined side categories |
[enumeration] TMAType | Enumerates the defined types of TMA services |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator |
space |


  • Type definitions

type |
 | space
space
space


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space
space
space


  • Type definitions
  • CantonType

CantonType enumeration type |  |
Enumerates the defined Swiss cantons or neighboring countries. |  | space
space
Set of enumeration values |  | 32 elements
enCantonUndefined: 0 | The canton is undefined |
enAG: 1 | The Swiss canton AG |
enAI: 2 | The Swiss canton AI |
enAR: 3 | The Swiss canton AR |
enBE: 4 | The Swiss canton BE |
enBL: 5 | The Swiss canton BL |
enBS: 6 | The Swiss canton BS |
enFR: 7 | The Swiss canton FR |
enGE: 8 | The Swiss canton GE |
enGL: 9 | The Swiss canton GL |
enGR: 10 | The Swiss canton GR |
enJU: 11 | The Swiss canton JU |
enLU: 12 | The Swiss canton LU |
enNE: 13 | The Swiss canton NE |
enNW: 14 | The Swiss canton NW |
enOW: 15 | The Swiss canton OW |
enSG: 16 | The Swiss canton SG |
enSH: 17 | The Swiss canton SH |
enSO: 18 | The Swiss canton SO |
enSZ: 19 | The Swiss canton SZ |
enTG: 20 | The Swiss canton TG |
enTI: 21 | The Swiss canton TI |
enUR: 22 | The Swiss canton UR |
enVD: 23 | The Swiss canton VD |
enVS: 24 | The Swiss canton VS |
enZG: 25 | The Swiss canton ZG |
enZH: 26 | The Swiss canton ZH |
enLiechtenstein: 27 | The country is Liechtenstein |
enAustria: 28 | The country is Austria |
enGermany: 29 | The country is Germany |
enItaly: 30 | The country is Italy |
enFrance: 31 | The country is France |
space


  • Type definitions
  • DATE

DATE type |
A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date. | space
space
space


  • Type definitions
  • double

double type |
An 8-byte IEEE real value | space
space
space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning | space
space
space


  • Type definitions
  • ISearch005

ISearch005 type |
ISearch005 interface | space
space
space


  • Type definitions
  • ISearchTMA

ISearchTMA type |
ISearchTMA interface | space
space
space


  • Type definitions
  • IValidate005

IValidate005 type |
IValidate005 interface | space
space
space


  • Type definitions
  • IValidateTMA

IValidateTMA type |
IValidateTMA interface | space
space
space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages |  | space
space
Set of enumeration values |  | 3 elements
enGerman: 1 | language German |
enFrench: 2 | language French |
enItalian: 3 | language Italian |
space


  • Type definitions
  • LawType

LawType enumeration type |  |
Enumerates the supported legal law set. |  | space
space
Set of enumeration values |  | 5 elements
enKVG: 0 | The applicable law is KVG - "Krankenversicherungsgesetz" |
enUVG: 1 | The applicable law is UVG - "Unfallversicherungsgesetz" |
enMVG: 2 | The applicable law is MVG - "Militäversicherungsgesetz" |
enIVG: 3 | The applicable law is IVG - "Invalidenversicherungsgesetz" |
enVVG: 4 | The applicable law is VVG - "Versicherungsvertragsgesetz" |
space


  • Type definitions
  • long

long type |
A 4-byte integer value | space
space
space


  • Type definitions
  • PlaceType

PlaceType enumeration type |  |
Enumerates the defined places where the main provider is located |  | space
space
Set of enumeration values |  | 6 elements
enPlaceUndefined: 0 | the place is not yet defined |
enPlacePractice: 1 | place is Practice Note that enPlacePractice, enPlaceLab, enPlaceAssociation, enPlaceCompany are treated as synonyms for a working place that is not a hospital |
enPlaceHospital: 2 | place is Hospital |
enPlaceLab: 4 | place is Laboratory Note that enPlacePractice, enPlaceLab, enPlaceAssociation, enPlaceCompany are treated as synonyms for a working place that is not a hospital |
enPlaceAssociation: 8 | place is Association Note that enPlacePractice, enPlaceLab, enPlaceAssociation, enPlaceCompany are treated as synonyms for a working place that is not a hospital |
enPlaceCompany: 16 | place is Company Note that enPlacePractice, enPlaceLab, enPlaceAssociation, enPlaceCompany are treated as synonyms for a working place that is not a hospital |
space


  • Type definitions
  • RoleType

RoleType enumeration type |  |
Enumerates the defined role categories that the main provider is best categorized |  | space
space
Set of enumeration values |  | 23 elements
enRoleUndefined: 0 | the role is not yet defined |
enRolePhysician: 1 | the role of the service provider is a university degree MD |
enRolePhysiotherapist: 2 | the role of the service provider is a physiotherapist |
enRoleChiropractor: 4 | the role of the service provider is a chiropractor |
enRoleErgotherapist: 8 | the role of the service provider is an ergotherapist |
enRoleNutritionist: 16 | the role of the service provider is a nutritionist including dietitians and nutrition advisors for diabetics |
enRoleMidwife: 32 | the role of the service provider is a midwife |
enRoleLogotherapist: 64 | the role of the service provider is a logotherapist |
enRoleHospital: 128 | this is a "virtual" role covering any medical/paramedical role in a hospital |
enRolePharmacist: 256 | the role of the service provider is a pharmacist |
enRoleDentist: 512 | the role of the service provider is a dentist including dental hygienists |
enRoleLabTechnician: 1024 | the role of the service provider is a laboratory technician |
enRoleDentalTechnician: 2048 | the role of the service provider is a dental technician |
enRoleOtherTechnician: 4096 | the role of the service provider is a technician including shoemakers other than dental or lab technicians |
enRolePsychologist: 16384 | the role of the service provider is psychologist |
enRoleFlatrateService: 32768 | this is a "virtual" role covering services of flat rate tariffs like 910,920,930,940 |
enRoleWholesaler: 65536 | the role of the service provider is a wholesaler |
enRoleNursingStaff: 131072 | the role of the service provider either from the nursing staff or nursing auxiliary |
enRoleTransport: 262144 | the role of the service provider is from the transport area e.g. ambulance or carrier |
enRoleDruggist: 524288 | the role of the service provider is a druggist |
enRoleNaturopathicDoctor: 1048576 | the role of the service provider covers professionals of natural medicine other than university degree MDs |
enRoleNaturopathicTherapist: 2097152 | the role of the service provider covers therapists of natural medicine as well as professionals of the wellness area |
enRoleOther: 4194304 | the role of the service provider is not explicitly mentioned in the list |
space


  • Type definitions
  • ServicePropertyType

ServicePropertyType enumeration type |  |
Defines properties a service possibly can possess in terms of an orthogonal bit list. |  | space
space
Set of enumeration values |  | 6 elements
enServicePropertyHasTP: 1 | This bit position characterizes the service as one with a fixed tax point (TP) as opposed to a variable TP services. |
enServicePropertyIsNeedsRefCode: 32 | This bit position characterizes the service as one that needs a reference code basically defining a chain of codes. If a service needs a reference code than that referenced service must be supplied prior than the current service. To retrieve the possible slave codes of a certain master code, use the ISearchTMA::Search4Slaves method. |
enServicePropertyHasSideDependency: 256 | This bit position characterizes the TMA service as side dependend that is when using the service the side must be greater than enSideNone. |
enServicePropertyIsGroupingRelevant: 512 | This bit position characterizes the TMA service as grouper relevant service, that is mostly of TMA type P(OR) or P(notOR). |
enServicePropertyIsMinutageService: 1024 | This bit position characterizes the TMA service as a minutage type service. |
enServicePropertyIsContactRelated: 2048 | This bit position characterizes the TMA service as contact related |
space


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined gender categories |  | space
space
Set of enumeration values |  | 2 elements
enMale: 0 | gender is Male |
enFemale: 1 | gender is Female |
space


  • Type definitions
  • SideType

SideType enumeration type |  |
Enumerates the defined side categories |  | space
space
Set of enumeration values |  | 4 elements
enSideNone: 0 | There is no side dependency |
enSideLeft: 1 | There is a Left side dependency |
enSideRight: 2 | There is a right side dependency |
enSideBoth: 3 | There is a dependency for both sides |
space


  • Type definitions
  • TMAType

TMAType enumeration type |  |
Enumerates the defined types of TMA services |  | space
space
Set of enumeration values |  | 9 elements
enTMATypeAny: 0 | The TMA service has an unknown type (is never set!!) AND given in a filter it does not filter at all! |
enTMATypeIsPOR: 1 | The TMA service is a main trigger service P and is element of the OR group (Partition O, LKAAT). This is in short abreviated by P(OR). |
enTMATypeIsPNotOR: 2 | The TMA service is a main trigger service P and is NOT element of the OR group. This is in short abreviated by P(notOR). |
enTMATypeIsP: 3 | The type is never returned but used as a filter it does selected P(OR)+P(notOR) = P. |
enTMATypeIsPZ: 4 | The TMA service is an additional service PZ, which can only be used with an P service as reference code. This is in short abreviated by PZ. |
enTMATypeIsE: 5 | The TMA service a 'TarDoc like' main service E. This is in short abreviated by E. |
enTMATypeIsEZ: 6 | The TMA service a 'TarDoc like' additional service EZ, which can only be used with an E service as reference code. This is in short abreviated by EZ. |
enTMATypeIsN: 7 | The TMA service not an E nor a P service e.g. "C00.AA.0010 - Hämodialyse". This is in short abreviated by N. |
enTMATypeIsPandE: 8 | There is no service of type P+E, but used as filter it does select both P as well as E services! |
space


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space
space
space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator |  | space
space
Set of enumeration values |  | 2 elements
enNo: 0 | boolean value No. |
enYes: 1 | boolean value Yes. |
space


 Sumex1 under a 64bit architecture...

All Sumex1 COM modules are written as 32bit managed C++ dll. As a consequence, a 64bit executable cannot load a 32bit COM dll into its process space due to the addressing differences.

Since some necessary underlying sub-modules are not available in a 64bit version, this problem must be addressed differently than by a 64bit compilation. As Microsoft suggests Sumex1 uses the out-of-process proxy approach where a 32bit COM server loads the 32bit COM dll into its process space and delegates each method call to the dll. Since a 32bit COM server exists in its own process space, the main 64bit process can handle the 64/32bit boundary without problems.

As a result, each 32bit Sumex1 COM dll has a 32bit COM server counterpart with the same name and an oopProxy prefix, e.g. oopProxyAcfValidator100.exe, where the prefix signifies the out-of-process proxy nature of the executable.

Any 64bit software now creates an instance of the 32bit oopProxy server and then calls the same methods and properties as with the 32bit COM dll. However, there is one crucial difference when using the oopProxy mechanism, namely the necessity to forcefully unload to the COM server at the end e.g. by using Marshal.ReleaseComObject() since the automatic garbage collection approach is too error prone.


 Important features of the acfValidator100 module

Can I input an ICD10 code into an ACF service record?

The tariff "005 - ACF" does not define any reference codes. For this reason, any ICD10 code can be stored in the 'referenceCodes' field!

  • The acfValidator100 understands this connection and ignores this reference code during validation.
  • The generalInvoiceRequestManager500 understands this connection, extracts the ICD10 code, and automatically saves it in the xtraService section.

How to handle the usage of the drug "7680664950014 = SPINRAZA Inj Sol 12 mg/5ml"?

The drug "7680664950014 = SPINRAZA Inj Sol 12 mg/5ml" is included into the LKAAT tariff as a P(notOR) trigger service and consequently can be added with AddService() by using the GTIN as code. It is unneccessary to supply the name.

Therefore, Spinraza is not treated as foreign service!

How to handle "foreign services" aka services not included in LKAAT?

Foreign services (services not included in the LKAAT) can be added as pro memoria services by supplying the name and the extended code tariffNumber@tariffCode (e.g. bstrCode= "402@7680444480250" and bstrName="DORMICUM 5 mg/ml i.v., i.m, rectal") with IValidateTMA::AddService(). Internally, the tariff number is stripped away and stored/returned under the reference code.

Furthermore, all foreign services are automatically defined as not grouper relevant, that is dExternalFactor=0 is set.


 General use of the acfValidator ATL COM module

The acfValidator comprises clear, dedicated steps in a specified sequence to ultimately achieve the desired result - an outpatient flat rate. The sequence shown below should be followed whenever possible:
  1. In the ISearchTMA interface, use Search4Trigger to search for the desired main trigger service (usually from P(OR)). Select one of the search results and add it to IValidateTMA::AddService.
  2. In the ISearchTMA interface, search for a suitable ICD code - important in the chapter shown in a) - using the Search4ICD method. Select one of the ICD codes shown and enter it together with the patient's gender and date of birth using IValidateTMA::AddACFBaseData - it is extremely important to use the same SessionNumber as in a).
  3. Use SearchGeneral to search for other TMA services that you believe are important and enter them using IValidateTMA::AddService. You can also skip this step!
  4. Now use DependencyTreeWalker to obtain a static decision tree diagram. At each node from top to bottom, a yes/no decision must be made until you reach the end point - the ACF code. Each yes decision requires the corresponding TMA service to be added via IValidateTMA::AddService (with the same SessionNumber) - the flat rate code achieved is no longer entered.
  5. You can now perform the grouping with IValidateTMA:RunGrouper or verify that you have achieved the corresponding flat rate code.
  6. Enter the code, the SessionNumber, and the ICD10 code (use the variable referenceCode) under IValidate005::AddService.
  7. Read and save all service data in order to enter it in the invoice in generalInvoiceRequest500.


 Introduction, overview and usage of the Restful Webservice Server

The application acfValidatorServer100.exe is a Restful Webservice Server, that has the same interface methods/properties as the COM module acfValidator100.dll. This allows to create a programming semantically similar to the COM approach but under the Restful Webservice paradigm. Consequently, on the Restful Client side there are no prevailing dependencies on Microsoft platforms and/or on Microsoft resources such as the database technology. Of course, the installation location of the server software is still subject to these restrictions.

In the next section of this document, the installation, configuration and operation of acfValidatorServer100.exe will be addressed.

Installation, registration and parameterization:
By installing the installer object acfValidator100 the COM module acfValidator100.dll as well as the out-of-process proxy component oopAcfValidator100.exe is automatically installed/registered in the system. However, the acfValidatorServer100.exe must be installed manually as a service.
acfValidatorServer100.exe -help | Creates a help window with the the name and full version of the applicationb as well as the currently define Webservice Endpoint. Furthermore the complete list of command line switches is shown.
acfValidatorServer100.exe -install | Installs/registers the Restful Webservice Server as a service. Please take into account, that the installation must be performed under administrator privileges
acfValidatorServer100.exe -uninstall | Uninstalls the service component. Please take into account, that the uninstallation must be performed under administrator privileges
acfValidatorServer100.exe -setport X | Sets the port X as part of the Webservice Endpoint
Restful Webservice Endpoint:
Installing acfValidatorServer100.exe as a service activates the Restful Webservice Endpoint:
http://localhost:34478/acfValidatorServer100
which is subsumed as baseURL in subsequent the API documentation.

To run the webservice under a different URL or under https protocol, a permanent webservice target endpoint mapping is performed on the target system.
For example, under Apache, the following rewrite rule is defined:
<VirtualHost *:*>
    ProxyPreserveHost Off
    Header always set Access-Control-Allow-Origin "*"
    Header always set Access-Control-Max-Age "1000"
    Header always set Access-Control-Allow-Headers "x-requested-with, Content-Type, origin, authorization, accept, client-security-token"

    ProxyPass /acfValidator/100/ http://localhost:34478/acfValidatorServer100/
    ProxyPassReverse /acfValidator/100/ http://localhost:34478/acfValidatorServer100/
</VirtualHost>
Restful Webservice Operation:
The service may be modified after installation, for example to start under a different account, to extend the recovery properties or to change the startup type. Finally, this should be set to 'Automatic' or 'Automatic (Delayed start)' so that the service is automatically available after a system restart.
Remarks about programming:
In the rest of this document we will discuss programming of the Restful web service and the differences to the C/C++ programming of the classic COM component.

As already mentioned, Restful programming is analogous to C++ programming with the addition that each instance of an interface (including the main interface) is created via the corresponding GET function. For example, an instance of the main interface is created with:
baseURL/IAcfValidator/GetAcfValidator | returns the instance address as JSON out{pIAcfValidator: longValue,...}
In every further call of a method or a property of the main interface this instance address must be included as part of the JSON-In. The termination/deletion of an instance must be done via the corresponding PUT Destruct property:
baseURL/IAcfValidator/PutDestructAcfValidator | with JSON-In{pIAcfValidator: longValue}, deletes the corresponding main instance AND all at that moment still active dependent subinstances (subinstances which have been generated by the explicit main instance).
It should be noted that the webserver acfValidatorServer100.exe performs an internal management of the generated instances and automatically deletes instances that have no activity for a defined period of 2 hours. no activity over a defined period of 2 hours. If after this action a rest call with such an instance is made, an error (HTTP Status >= 400) is generated and the instance address is marked as unknown.
Code snippet:
Minimal code snippet to query the version of the module and the associated database:
    http://localhost:34478/acfValidatorServer100/IAcfValidator/GetAcfValidator
        returns JSON-Out{pIAcfValidator: 34161}

    http://localhost:34478/acfValidatorServer100/IAcfValidator/GetModuleVersion?pIAcfValidator=34161
        returns JSON-Out{pbstrModuleVersion: "1.00.010"}

    http://localhost:34478/acfValidatorServer100/IAcfValidator/GetDBVersionText?pIAcfValidator=34161
        returns JSON-Out{pbstrDBVersionText: "3.22"}

    http://localhost:34478/acfValidatorServer100/IAcfValidator/GetDBVersionDate?pIAcfValidator=34161
        returns JSON-Out{pdDBVersionDate: "2021-11-29"}

    http://localhost:34778/acfValidatorServer100/IAcfValidator/GetValidateTMA?pIAcfValidator=34161
        returns JSON-Out{pIValidate: 47008}

    http://localhost:34778/acfValidatorServer100/IValidate/PutDestructValidateTMA
        JSON-IN(pIValidate: 47008}

    http://localhost:34478/acfValidatorServer100/IAcfValidator/PutDestructAcfValidator
        JSON-IN{pIAcfValidator:34161}